summaryrefslogtreecommitdiff
path: root/dev-ruby/addressable
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
commit814f4cf860e299a046b649eaee5463427984c09c (patch)
tree74c45f097899310e599dad6b8df5b63e0f085bc0 /dev-ruby/addressable
parent7f0ccc917c7abe6223784c703d86cd14755691fb (diff)
gentoo resync : 08.07.2021
Diffstat (limited to 'dev-ruby/addressable')
-rw-r--r--dev-ruby/addressable/Manifest2
-rw-r--r--dev-ruby/addressable/addressable-2.8.0.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/addressable/Manifest b/dev-ruby/addressable/Manifest
index a8f7a4be9af8..ca547bbcc69e 100644
--- a/dev-ruby/addressable/Manifest
+++ b/dev-ruby/addressable/Manifest
@@ -1,5 +1,7 @@
DIST addressable-2.6.0.gem 104448 BLAKE2B 664365962533d31786e2a362b61879fee544867b7aadc2ceb1ae6709374015a7f0f5c0bd32a81c8f2ae711a4ce1a07cd8f84821e74c3b6aa56b7474800567737 SHA512 71aa0ce8b61a07c1d01298dcd29cb2ba73d06ed1578908cae60351214f7d0bc6c9b8b0db7a78044fb1bed258bf00f2f093aa4e2bcb32575f4db2a79ee36b2648
DIST addressable-2.7.0.gem 104960 BLAKE2B 4bca65d54ef1d3556cf4017ae68082635c0398b6f604eb3edc18da8f8e1e49e38b46485a8716da3c407fe0605dcc9a12c7a95be49a91c4198c2e2b1cab568805 SHA512 4c438bbfa8874fdcf11eef1d1f7cceb1855ea85948daff13615a0af129d35f92cc918f4bd5bbe4cd6ebccc67a86fc582265f915dc39831ec64209de0bdeeb732
+DIST addressable-2.8.0.gem 105984 BLAKE2B 82f053c9ad052ce1ed1b6927674bd5bcda86a3f70d46b63bfc1185d51b402996fd446647d705418791c5443a1767b4ecd0b891f26de63fbe737c62f7586bd57c SHA512 c684f17940f717c2a65f9716ab9b3659948d6d51a60c38a7295fcf6fdc1c5785d2d315d2de7dab9f66a6c31f62247177d78d5d6eb556f5bb49926d4f00f8e4c8
EBUILD addressable-2.6.0.ebuild 1343 BLAKE2B b225c1f2f7a58272e83b7a6be35aeb220a2f5cc1f94185259179f3ed89356eefc90ec03ba65631c4c676981d841a6f8b7b9782de203b3876a6451f6fb1baf165 SHA512 2305bb1ad32f470d303ab3b702ebb6bcf2056233c997be75be3c802d653e8386bc29d5ff8666dfe477edacb0a2b62bf5a9b3bb0ba44c55e208459197bd6a44b3
EBUILD addressable-2.7.0.ebuild 1310 BLAKE2B 9a404fd941bf78f539164435864da9dcababa6a7188eebb182b2c23511cda0b849ef10937d7fc5728c9cf853a50c588548936f87b359e44d98accaa22a238ab3 SHA512 65256c662589db08c03be5db84c6805a11a685eeb4d47c5f1fdff2651b63ab980b891714d2da11000f2a3b0849049768462c6bd67b15f5f9093ec026dd61e2c3
+EBUILD addressable-2.8.0.ebuild 1310 BLAKE2B 9a404fd941bf78f539164435864da9dcababa6a7188eebb182b2c23511cda0b849ef10937d7fc5728c9cf853a50c588548936f87b359e44d98accaa22a238ab3 SHA512 65256c662589db08c03be5db84c6805a11a685eeb4d47c5f1fdff2651b63ab980b891714d2da11000f2a3b0849049768462c6bd67b15f5f9093ec026dd61e2c3
MISC metadata.xml 404 BLAKE2B 4362f3592286dd6cffae99340e1b4437af10ab4dbbe44585d3370b0970e7d02a881853329c9412bfc881c3f040995a204b758aead2c34cba4f9df8104f858479 SHA512 c335566562492b85e491233d4f908fe18c2713ed9ac3afe2cb4d9537d71bdfa1a10bf58f1ca9f29e5a695fde9a4ba0ff9b3c57122afe78907cc0b00b5c307351
diff --git a/dev-ruby/addressable/addressable-2.8.0.ebuild b/dev-ruby/addressable/addressable-2.8.0.ebuild
new file mode 100644
index 000000000000..444a23a8b9eb
--- /dev/null
+++ b/dev-ruby/addressable/addressable-2.8.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A replacement for the URI implementation that is part of Ruby's standard library"
+HOMEPAGE="https://rubygems.org/gems/addressable https://github.com/sporkmonger/addressable"
+
+LICENSE="Apache-2.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_rdepend "|| ( dev-ruby/public_suffix:4 dev-ruby/public_suffix:3 )"
+
+ruby_add_bdepend "test? ( dev-ruby/rspec-its )"
+
+all_ruby_prepare() {
+ # Remove spec-related tasks so that we don't need to require rspec
+ # just to build the documentation, bug 383611.
+ sed -i -e '/spectask/d' Rakefile || die
+ rm -f tasks/rspec.rake || die
+ sed -i -e '/bundler/ s:^:#:' \
+ -e '/^begin/,/^end/ s:^:#:' \
+ spec/spec_helper.rb || die
+
+ # Remove specs requiring network connectivity
+ rm -f spec/addressable/net_http_compat_spec.rb || die
+
+ # Remove spec that tests against an unreleased github fork
+ rm -f spec/addressable/rack_mount_compat_spec.rb || die
+}