summaryrefslogtreecommitdiff
path: root/dev-ruby/asciidoctor-diagram/asciidoctor-diagram-2.2.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-09 16:33:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-09 16:33:39 +0100
commit785047acce64d1217286105397cc6fe433c34cb3 (patch)
tree714041fe6d930b5e1c4f005d501fdb914c4834b5 /dev-ruby/asciidoctor-diagram/asciidoctor-diagram-2.2.11.ebuild
parent6440e1dd038e7df4f9df7dd5127d3b1c6f39034e (diff)
gentoo auto-resync : 09:09:2023 - 16:33:38
Diffstat (limited to 'dev-ruby/asciidoctor-diagram/asciidoctor-diagram-2.2.11.ebuild')
-rw-r--r--dev-ruby/asciidoctor-diagram/asciidoctor-diagram-2.2.11.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-ruby/asciidoctor-diagram/asciidoctor-diagram-2.2.11.ebuild b/dev-ruby/asciidoctor-diagram/asciidoctor-diagram-2.2.11.ebuild
new file mode 100644
index 000000000000..cb24f379e007
--- /dev/null
+++ b/dev-ruby/asciidoctor-diagram/asciidoctor-diagram-2.2.11.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.adoc LICENSE.txt README.adoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A set of Asciidoctor extensions that enable you to add diagrams"
+HOMEPAGE="https://github.com/asciidoctor/asciidoctor-diagram"
+SRC_URI="https://github.com/asciidoctor/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND+=" virtual/jre"
+DEPEND+=" test? (
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ media-gfx/imagemagick[png,postscript]
+ media-gfx/graphviz
+ media-sound/lilypond
+ sci-visualization/gnuplot
+)"
+ruby_add_rdepend ">=dev-ruby/asciidoctor-1.5.7 <dev-ruby/asciidoctor-3"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -e '/c.formatter/ s:^:#:' \
+ -e '/logger.*DEBUG/ s:^:#:' \
+ -i spec/test_helper_methods.rb || die
+
+ # Remove some diagram dependencies that contains vendored code and
+ # are currently not packaged. Please file a bug if you have a need
+ # for these diagram types.
+ sed -i -e '/\(ditaamini\|plantuml\)/ s:^:#:' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid specs for unpackaged tools
+ rm -f spec/{a2s,barcode,blockdiag,bpmn,bytefield,d2,dbml,diagrams,ditaa,dpic,erd,graphviz_py,mermaid,msc,nomnoml,pikchr,plantuml,shaape,smcat,structurizr,svgbob,symbolator,syntrax,umlet,vega,wavedrom}_spec.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+}