summaryrefslogtreecommitdiff
path: root/dev-ruby/asciidoctor/asciidoctor-2.0.18.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-18 15:59:06 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-18 15:59:06 +0000
commit1778ddeb0f60c074ffc7fa775557ddb37c997127 (patch)
tree8622467260dfc905fd268290438b05e3a9fd06da /dev-ruby/asciidoctor/asciidoctor-2.0.18.ebuild
parentd93ba9788a6ad1e5da2bf47e804456ded6d5c65c (diff)
gentoo auto-resync : 18:12:2022 - 15:59:06
Diffstat (limited to 'dev-ruby/asciidoctor/asciidoctor-2.0.18.ebuild')
-rw-r--r--dev-ruby/asciidoctor/asciidoctor-2.0.18.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-ruby/asciidoctor/asciidoctor-2.0.18.ebuild b/dev-ruby/asciidoctor/asciidoctor-2.0.18.ebuild
new file mode 100644
index 000000000000..2b122dc2ee85
--- /dev/null
+++ b/dev-ruby/asciidoctor/asciidoctor-2.0.18.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_TASK_TEST="CUCUMBER_PUBLISH_QUIET=true test features"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.adoc README.adoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+RUBY_FAKEGEM_GEMSPEC="asciidoctor.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Processor for converting AsciiDoc into HTML 5, DocBook 4.5 and other formats"
+HOMEPAGE="https://github.com/asciidoctor/asciidoctor"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-util/cucumber
+ dev-ruby/rspec-expectations:*
+ dev-ruby/asciimath
+ dev-ruby/coderay
+ dev-ruby/concurrent-ruby
+ dev-ruby/erubi
+ dev-ruby/haml
+ dev-ruby/nokogiri
+ dev-ruby/rouge
+ dev-ruby/slim
+ dev-ruby/tilt )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+
+ sed -i -e "s:_relative ': './:" ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid broken blocks_test.rb (already appears to be fixed upstream)
+ rm -f test/blocks_test.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/asciidoctor.1
+}