summaryrefslogtreecommitdiff
path: root/dev-ruby/astrolabe
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ruby/astrolabe
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ruby/astrolabe')
-rw-r--r--dev-ruby/astrolabe/Manifest1
-rw-r--r--dev-ruby/astrolabe/astrolabe-1.3.1-r1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/astrolabe/Manifest b/dev-ruby/astrolabe/Manifest
index 59b4c361a8eb..36c791415fdb 100644
--- a/dev-ruby/astrolabe/Manifest
+++ b/dev-ruby/astrolabe/Manifest
@@ -1,3 +1,4 @@
DIST astrolabe-1.3.1.gem 16384 BLAKE2B 4853c4c9c8fb926c8f58f6c940f22e44e20db7b3b7c853a0ea120657074cb0bfb42b3a22832042fcb27546e2ab3e32c526c93ccd3ea4d43f17c8e0c09fd2fbf8 SHA512 db29d26559e4adb82e4a25a3b7d3df94fcb9847dbd65abdb25abd0181b60af2e0fe0021bb8193c5f94d58e074da06de3d1f7170cb341ac675e3c3ab39ba95bef
+EBUILD astrolabe-1.3.1-r1.ebuild 746 BLAKE2B d0957cc4878fdf137c68922c914713718ee51cc634a497254d5e9ad106920a82c7e0bb8ad68660c2b154c10659eb0f388d7e830d34da5117ef1e462d18a3ec75 SHA512 7b4ee02d5a9dbca6c4755b7dc3e1e70b062265245c49590cdaf730a7b8ee67f5960086d6112a75757ffed6d323f82a4d75e3661b72d92c3825da271a63e2b649
EBUILD astrolabe-1.3.1.ebuild 753 BLAKE2B 1a099d8a99f24b413eb46be9b8f34bcd22dcf8c20fa20bc19808805f4da4a69459f7c720bdb211fc2b96e889a550b6d9808b66c6cf80b9cca161ebb8ae3989b5 SHA512 ecaec37e6ec95b00e25861c2573cfbe9572e846b3f1c352a7fb10de2c42bf206bf1956cccd47a9bc64105799f73909a76de666e6a4be4c13bf4cb84aaef715da
MISC metadata.xml 348 BLAKE2B 7d999da9a49726292bc0c44f26b0ba86f093340a4ffc1d211f0a0f8510c9de6ff4d2dcf90e1307683073c87aa45d77aab6b050a7fb2241be9458a6f649924f97 SHA512 ca7e080c9465cf8f8c1607ffbb9a39a8bc17a00e3f0d60ff35d3d3d21bc33c00a4d6d7e647ac8c309df75d6406e48acf6b02858127d3be247d54f0da63f537b4
diff --git a/dev-ruby/astrolabe/astrolabe-1.3.1-r1.ebuild b/dev-ruby/astrolabe/astrolabe-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..09912a68a210
--- /dev/null
+++ b/dev-ruby/astrolabe/astrolabe-1.3.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An object-oriented AST extension for Parser"
+HOMEPAGE="https://github.com/yujinakayama/astrolabe"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/parser-2.2.0_pre3"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ # Fix Specs until RSpec3 is available
+ sed -i -e "/mocks.verify_partial_doubles/ s/^/#/" spec/spec_helper.rb || die
+ sed -i -e "s/is_expected.to/should/" spec/astrolabe/node_spec.rb || die
+}