summaryrefslogtreecommitdiff
path: root/dev-ruby/astrolabe
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/astrolabe
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/astrolabe')
-rw-r--r--dev-ruby/astrolabe/Manifest3
-rw-r--r--dev-ruby/astrolabe/astrolabe-1.3.1.ebuild28
-rw-r--r--dev-ruby/astrolabe/metadata.xml11
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/astrolabe/Manifest b/dev-ruby/astrolabe/Manifest
new file mode 100644
index 000000000000..ef9399884ee0
--- /dev/null
+++ b/dev-ruby/astrolabe/Manifest
@@ -0,0 +1,3 @@
+DIST astrolabe-1.3.1.gem 16384 BLAKE2B 4853c4c9c8fb926c8f58f6c940f22e44e20db7b3b7c853a0ea120657074cb0bfb42b3a22832042fcb27546e2ab3e32c526c93ccd3ea4d43f17c8e0c09fd2fbf8 SHA512 db29d26559e4adb82e4a25a3b7d3df94fcb9847dbd65abdb25abd0181b60af2e0fe0021bb8193c5f94d58e074da06de3d1f7170cb341ac675e3c3ab39ba95bef
+EBUILD astrolabe-1.3.1.ebuild 756 BLAKE2B 1cc69baa0375c0417063720d0a4972d54117aaa1658dd84f78e4e7757718373747a854034ab4518972828199ba4c1c040626b937fb1a1a703340e78244b4e8a3 SHA512 a13e2bd9bf93c44ff673c816e1dcfd082ac46ab3107d67366fb09ebb06e7bc0f0ddfad7fcbee07951de9045b4768537a465b2d27f909ef64b422df1549ea436c
+MISC metadata.xml 348 BLAKE2B 7d999da9a49726292bc0c44f26b0ba86f093340a4ffc1d211f0a0f8510c9de6ff4d2dcf90e1307683073c87aa45d77aab6b050a7fb2241be9458a6f649924f97 SHA512 ca7e080c9465cf8f8c1607ffbb9a39a8bc17a00e3f0d60ff35d3d3d21bc33c00a4d6d7e647ac8c309df75d6406e48acf6b02858127d3be247d54f0da63f537b4
diff --git a/dev-ruby/astrolabe/astrolabe-1.3.1.ebuild b/dev-ruby/astrolabe/astrolabe-1.3.1.ebuild
new file mode 100644
index 000000000000..61abe54ff9fb
--- /dev/null
+++ b/dev-ruby/astrolabe/astrolabe-1.3.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An object-oriented AST extension for Parser"
+HOMEPAGE="https://github.com/yujinakayama/astrolabe"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/parser-2.2.0_pre3"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ # Fix Specs until RSpec3 is available
+ sed -i -e "/mocks.verify_partial_doubles/ s/^/#/" spec/spec_helper.rb || die
+ sed -i -e "s/is_expected.to/should/" spec/astrolabe/node_spec.rb || die
+}
diff --git a/dev-ruby/astrolabe/metadata.xml b/dev-ruby/astrolabe/metadata.xml
new file mode 100644
index 000000000000..ca98a067c345
--- /dev/null
+++ b/dev-ruby/astrolabe/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">yujinakayama/astrolabe</remote-id>
+ </upstream>
+</pkgmetadata>