summaryrefslogtreecommitdiff
path: root/dev-ruby/autoprefixer-rails/autoprefixer-rails-7.2.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-02 15:59:12 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-02 15:59:12 +0000
commit06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (patch)
tree8d58c1f4b049da677b33209b072f2b3057268fe0 /dev-ruby/autoprefixer-rails/autoprefixer-rails-7.2.6.ebuild
parent99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (diff)
gentoo resync : 02.03.2018
Diffstat (limited to 'dev-ruby/autoprefixer-rails/autoprefixer-rails-7.2.6.ebuild')
-rw-r--r--dev-ruby/autoprefixer-rails/autoprefixer-rails-7.2.6.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/autoprefixer-rails/autoprefixer-rails-7.2.6.ebuild b/dev-ruby/autoprefixer-rails/autoprefixer-rails-7.2.6.ebuild
new file mode 100644
index 000000000000..c4f4758fd095
--- /dev/null
+++ b/dev-ruby/autoprefixer-rails/autoprefixer-rails-7.2.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="vendor"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Add vendor prefixes to CSS rules using values from the Can I Use website"
+HOMEPAGE="https://github.com/ai/autoprefixer-rails"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="7"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/execjs:*"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rails
+ dev-ruby/rake
+ dev-ruby/rspec-rails
+)"
+
+all_ruby_prepare() {
+ sed -i -e "/bundler/d" -e "/BUNDLE/d" spec/app/config/boot.rb || die
+ sed -i -e "/Bundler/,+3d" spec/app/config/application.rb || die
+ rm spec/rails_spec.rb spec/compass_spec.rb || die
+}