summaryrefslogtreecommitdiff
path: root/dev-ruby/autoprefixer-rails/autoprefixer-rails-8.6.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-07 11:42:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-07 11:42:03 +0100
commitf70601e0934acd62f6c5d06c5ede4cc607179514 (patch)
tree0b337390375de04b950fc4b45edc0f895a4701a4 /dev-ruby/autoprefixer-rails/autoprefixer-rails-8.6.4.ebuild
parentb2be182d49eea46686b5cf2680d457df61e89dc4 (diff)
gentoo resync : 07.07.2018
Diffstat (limited to 'dev-ruby/autoprefixer-rails/autoprefixer-rails-8.6.4.ebuild')
-rw-r--r--dev-ruby/autoprefixer-rails/autoprefixer-rails-8.6.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/autoprefixer-rails/autoprefixer-rails-8.6.4.ebuild b/dev-ruby/autoprefixer-rails/autoprefixer-rails-8.6.4.ebuild
new file mode 100644
index 000000000000..f623a7c290e0
--- /dev/null
+++ b/dev-ruby/autoprefixer-rails/autoprefixer-rails-8.6.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="vendor"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Add vendor prefixes to CSS rules using values from the Can I Use website"
+HOMEPAGE="https://github.com/ai/autoprefixer-rails"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="8"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/execjs:*"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rails
+ dev-ruby/rake
+ dev-ruby/rspec-rails
+)"
+
+all_ruby_prepare() {
+ sed -i -e "/bundler/d" -e "/BUNDLE/d" spec/app/config/boot.rb || die
+ sed -i -e "/Bundler/,+3d" spec/app/config/application.rb || die
+ rm spec/rails_spec.rb spec/compass_spec.rb || die
+}