summaryrefslogtreecommitdiff
path: root/dev-ruby/aws-s3/aws-s3-0.6.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/aws-s3/aws-s3-0.6.3.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/aws-s3/aws-s3-0.6.3.ebuild')
-rw-r--r--dev-ruby/aws-s3/aws-s3-0.6.3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/aws-s3/aws-s3-0.6.3.ebuild b/dev-ruby/aws-s3/aws-s3-0.6.3.ebuild
new file mode 100644
index 000000000000..e913cbfe5787
--- /dev/null
+++ b/dev-ruby/aws-s3/aws-s3-0.6.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README"
+
+# there is a stupid setup.rb in the bin/ directory so do not use the
+# default.
+RUBY_FAKEGEM_BINWRAP="s3sh"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Client library for Amazon's Simple Storage Service's REST API"
+HOMEPAGE="http://amazon.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/xml-simple
+ dev-ruby/builder
+ dev-ruby/mime-types:*
+ virtual/ruby-ssl"
+ruby_add_bdepend "test? ( dev-ruby/flexmock )"
+
+RUBY_PATCHES=(
+ ${P}+ruby19.patch
+)
+
+all_ruby_prepare() {
+ # Avoid tests requiring network access, bug 339324
+ sed -i -e '/test_request_only_escapes_the_path_the_first_time_it_runs_and_not_subsequent_times/,/^ end/ s:^:#:' \
+ -e '/test_if_request_has_no_body_then_the_content_length_is_set_to_zero/,/^ end/ s:^:#:' \
+ test/connection_test.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -I. -e "Dir['test/*_test.rb'].each {|f| require f }" || die
+}