summaryrefslogtreecommitdiff
path: root/dev-ruby/axiom-types/axiom-types-0.1.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-ruby/axiom-types/axiom-types-0.1.1-r1.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-ruby/axiom-types/axiom-types-0.1.1-r1.ebuild')
-rw-r--r--dev-ruby/axiom-types/axiom-types-0.1.1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/axiom-types/axiom-types-0.1.1-r1.ebuild b/dev-ruby/axiom-types/axiom-types-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..d2a557a913ef
--- /dev/null
+++ b/dev-ruby/axiom-types/axiom-types-0.1.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING.md README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Define types with optional constraints for use within axiom and other libraries"
+HOMEPAGE="https://rubygems.org/gems/axiom-types https://github.com/dkubb/axiom-types"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/descendants_tracker-0.0.4
+ <dev-ruby/descendants_tracker-0.1
+ >=dev-ruby/ice_nine-0.11.0
+ <dev-ruby/ice_nine-0.12
+ >=dev-ruby/thread_safe-0.3.1
+ <dev-ruby/thread_safe-1"
+
+RESTRICT="test"