summaryrefslogtreecommitdiff
path: root/dev-ruby/bindata/bindata-2.4.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-14 11:04:34 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-14 11:04:34 +0100
commitdd762ff83c330186ee2ede002e08b2f780cddd51 (patch)
tree63198edcc3ad5df8e2566c28ff9bd8af50cc2174 /dev-ruby/bindata/bindata-2.4.4.ebuild
parent51af5f0eb4cddbe6aa7953717873691d77aae9ff (diff)
gentoo resync : 14.07.2019
Diffstat (limited to 'dev-ruby/bindata/bindata-2.4.4.ebuild')
-rw-r--r--dev-ruby/bindata/bindata-2.4.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/bindata/bindata-2.4.4.ebuild b/dev-ruby/bindata/bindata-2.4.4.ebuild
new file mode 100644
index 000000000000..e08c6e1a982d
--- /dev/null
+++ b/dev-ruby/bindata/bindata-2.4.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Parsing Binary Data in Ruby"
+HOMEPAGE="https://github.com/dmendel/bindata"
+
+LICENSE="BSD-2"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+ sed -i -e '/[Cc]overalls/d' test/test_helper.rb || die
+}