summaryrefslogtreecommitdiff
path: root/dev-ruby/bundler/bundler-2.2.33-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-18 20:36:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-18 20:36:58 +0100
commite26a7b5ef1fe42a66a3c91fe878da93c7cf83737 (patch)
tree69f8a3ce38afa952085fc96f7f7baaa8ad9fd0c8 /dev-ruby/bundler/bundler-2.2.33-r1.ebuild
parent3a1b8b124a5b405562b6e0ccf04e7bd2ddc131a4 (diff)
gentoo auto-resync : 18:07:2022 - 20:36:57
Diffstat (limited to 'dev-ruby/bundler/bundler-2.2.33-r1.ebuild')
-rw-r--r--dev-ruby/bundler/bundler-2.2.33-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/bundler/bundler-2.2.33-r1.ebuild b/dev-ruby/bundler/bundler-2.2.33-r1.ebuild
new file mode 100644
index 000000000000..9d50b60b14f3
--- /dev/null
+++ b/dev-ruby/bundler/bundler-2.2.33-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+# The specs require a number of gems to be installed in a temporary
+# directory, but this requires network access. They also don't work
+# when run with a path that contains "-".
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+# No documentation task
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+RUBY_FAKEGEM_BINDIR="exe"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An easy way to vendor gem dependencies"
+HOMEPAGE="https://github.com/carlhuda/bundler"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_rdepend virtual/rubygems
+
+RDEPEND+=" dev-vcs/git !<dev-ruby/bundler-1.17.3-r1:0"