summaryrefslogtreecommitdiff
path: root/dev-ruby/celluloid-pool
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/celluloid-pool
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/celluloid-pool')
-rw-r--r--dev-ruby/celluloid-pool/Manifest4
-rw-r--r--dev-ruby/celluloid-pool/celluloid-pool-0.20.5.ebuild37
-rw-r--r--dev-ruby/celluloid-pool/metadata.xml11
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-ruby/celluloid-pool/Manifest b/dev-ruby/celluloid-pool/Manifest
new file mode 100644
index 000000000000..48f3861d9698
--- /dev/null
+++ b/dev-ruby/celluloid-pool/Manifest
@@ -0,0 +1,4 @@
+DIST celluloid-pool-0.20.5.tar.gz 8796 SHA256 9ced0aab473b73044e0d8eccb7524e5865d92a2add9db917585792a721c80f76 SHA512 6bded1ee7bfeaebddd49af9c5d72d078da9ebd6817cebd6124f95c0303e20ea31417930e71680e9d75bd0ce21689e7b409cd13132d8f802d51b9eced67a79ae5 WHIRLPOOL b5309229f8667ee747ad5c07438b22460ebd87b525a154ad05239f87cd500c7f8d6c0f1dd5922fd396e946c78082c348b337256ac3e2de5f4bf2d0cc318191cc
+EBUILD celluloid-pool-0.20.5.ebuild 1033 SHA256 a5f9eeae87d2c38fecdb6caf0f5ac2919df17ec7a24d3ab273ab8757307d1456 SHA512 8af8d549d9d90ab0bf3c61f40e249956f6a06f14f1d5fc4530070b28e403d5623b9082c58ff6ac436e7d63a8bdfea7318e1d9d112c19882cf42a75b0e5b44b58 WHIRLPOOL f6a7ab742e8421a70f24bf3fb186da87bfed20a62de16638384ef4b21808fc3c8998b920dd1e5009496be7d4c0feee1c7aabfa5cc37a8a67d08b9c8631cc0bfd
+MISC ChangeLog 1020 SHA256 0f16eaf06f1717404c8f76943b640fcc48de0a33d9ad8d6f0ef287b6935b9df7 SHA512 58227d01457afbf36e9e084bbe9abda7a9f778ba618ff97cd1dcc9f403d00a554e685d02c88a746b49f0302d510baa6367857913b6f1d75d504588acab5a5deb WHIRLPOOL aab05dc1bc43b443c2a3627d5593bd4db4fa4d11b9ef10ba2d03db20fd62b4d6aec518060847f355fc692b586e9345efbb88ea14343c4ed4075b29107d52cc72
+MISC metadata.xml 350 SHA256 26764820d8569b1003068d354a4dcdc293b0905a9b4d8dc8bc03c010d231ee90 SHA512 7955fe1013fde07dac6165460f8679248c8124a6b67798dc2d5d6d381cbb61fe72a959dfa45e08b17c1aa0e9272206959e3b494c2e6b566405f717bb2c83fb98 WHIRLPOOL ef90453c5b0846e4bd752ba0960066795e8a636a653b9678de6b1622eb35904555872f70c25bbd82513c37f018f2a22a4b65078682b5ba7f83484291ee079452
diff --git a/dev-ruby/celluloid-pool/celluloid-pool-0.20.5.ebuild b/dev-ruby/celluloid-pool/celluloid-pool-0.20.5.ebuild
new file mode 100644
index 000000000000..c7fad83db216
--- /dev/null
+++ b/dev-ruby/celluloid-pool/celluloid-pool-0.20.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides a simple and natural way to build fault-tolerant concurrent programs"
+HOMEPAGE="https://github.com/celluloid/celluloid"
+SRC_URI="https://github.com/celluloid/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+IUSE=""
+SLOT="0"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+ruby_add_rdepend "
+ >=dev-ruby/timers-4.1.1"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/celluloid-0.17.2
+ dev-ruby/dotenv
+ dev-ruby/nenv
+ dev-ruby/rspec-retry
+)"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' -e '/coveralls/I s:^:#:' spec/spec_helper.rb || die
+
+ sed -i -e '1irequire "pathname"' spec/spec_helper.rb || die
+ sed -i -e "s:log/test.log:${TMPDIR}/test.log:" .env-dev || die
+}
diff --git a/dev-ruby/celluloid-pool/metadata.xml b/dev-ruby/celluloid-pool/metadata.xml
new file mode 100644
index 000000000000..98512b3bfd89
--- /dev/null
+++ b/dev-ruby/celluloid-pool/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">celluloid/celluloid-pool</remote-id>
+ </upstream>
+</pkgmetadata>