summaryrefslogtreecommitdiff
path: root/dev-ruby/celluloid-supervision
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/celluloid-supervision
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/celluloid-supervision')
-rw-r--r--dev-ruby/celluloid-supervision/Manifest3
-rw-r--r--dev-ruby/celluloid-supervision/celluloid-supervision-0.20.6.ebuild37
-rw-r--r--dev-ruby/celluloid-supervision/metadata.xml11
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-ruby/celluloid-supervision/Manifest b/dev-ruby/celluloid-supervision/Manifest
new file mode 100644
index 000000000000..c68581ef18dc
--- /dev/null
+++ b/dev-ruby/celluloid-supervision/Manifest
@@ -0,0 +1,3 @@
+DIST celluloid-supervision-0.20.6.tar.gz 16391 BLAKE2B c8c7d6c8ca569cee60d268df41bfd04e74d91cfc761918e608f21aa5fdcb69d28fde8725aa028ae3859d7e47fb9f098ce307940d4ebb0067ba98850a4961cf39 SHA512 f27d873641bf732822f1c65a8344a2c3bb611040ff0b3c72baff44ad3166f9a872e3dc536310a725f6ae91f1664ff72eba77c3192325ec52a25b7efee1beeaed
+EBUILD celluloid-supervision-0.20.6.ebuild 1043 BLAKE2B 55b8257fb8d287fdeb509a17f5e99017cb91ec33b1fa705aca6850acca4fe34d88f4989edd1a56aa38b95d99ea7eb9ecd5496441b6bf9c4fdaef00d0b1d06117 SHA512 916b3ffc83250d6f6845e896307818cebd6f34e44f81ad18a2d031b1a1fcc384694c96c9822e9595e1e02f9a593384854758c2d4d39ce28ff2df6691d27b40b6
+MISC metadata.xml 357 BLAKE2B 0dfccefff2a8cb93eed429de1cc502cc46657f87712ed6364ea58bd76d51f8b4c4c71e58d2eaf74dd813502d28202abf8f912558fbf5f0a706199a99e8ebebdf SHA512 b1bf81ea3a1cdbefa2e9e8684daf563f5ff5cd03d32e394ed606acab3d70523c4a0dd70429d2df6de44c6bd7cf5f8ed6719b6a8d9f726925fc12db436df7e58b
diff --git a/dev-ruby/celluloid-supervision/celluloid-supervision-0.20.6.ebuild b/dev-ruby/celluloid-supervision/celluloid-supervision-0.20.6.ebuild
new file mode 100644
index 000000000000..b1610ab0df52
--- /dev/null
+++ b/dev-ruby/celluloid-supervision/celluloid-supervision-0.20.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides a simple and natural way to build fault-tolerant concurrent programs"
+HOMEPAGE="https://github.com/celluloid/celluloid"
+SRC_URI="https://github.com/celluloid/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+IUSE=""
+SLOT="0"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+ruby_add_rdepend "
+ >=dev-ruby/timers-4.1.1"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/celluloid-0.17.2
+ dev-ruby/dotenv
+ dev-ruby/nenv
+ dev-ruby/rspec-retry
+)"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' -e '/coveralls/I s:^:#:' spec/spec_helper.rb || die
+
+ sed -i -e '1irequire "pathname"' spec/spec_helper.rb || die
+ sed -i -e "s:log/test.log:${TMPDIR}/test.log:" .env-dev || die
+}
diff --git a/dev-ruby/celluloid-supervision/metadata.xml b/dev-ruby/celluloid-supervision/metadata.xml
new file mode 100644
index 000000000000..e6a191fd5a64
--- /dev/null
+++ b/dev-ruby/celluloid-supervision/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">celluloid/celluloid-supervision</remote-id>
+ </upstream>
+</pkgmetadata>