summaryrefslogtreecommitdiff
path: root/dev-ruby/classifier-reborn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/classifier-reborn
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/classifier-reborn')
-rw-r--r--dev-ruby/classifier-reborn/Manifest3
-rw-r--r--dev-ruby/classifier-reborn/classifier-reborn-2.2.0.ebuild37
-rw-r--r--dev-ruby/classifier-reborn/metadata.xml11
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-ruby/classifier-reborn/Manifest b/dev-ruby/classifier-reborn/Manifest
new file mode 100644
index 000000000000..f35303ec578b
--- /dev/null
+++ b/dev-ruby/classifier-reborn/Manifest
@@ -0,0 +1,3 @@
+DIST classifier-reborn-2.2.0.tar.gz 319010 BLAKE2B f4bd3259b9d6e324f3f0feb06dfd1c8736eaa8ae0f687e488b6e11b9cda8e6bf9e56a175c01dfb9352184da1a030d1330e22917c7bfdcb4242fa0102f6291940 SHA512 d299ce8f3b96de5c6194e816d880ebb895faaacdc2a19985166bdc3d9760242ec41d85f22167ea66e9afd743f5d91d63881da02882d1a412fc95a0c5db63d04c
+EBUILD classifier-reborn-2.2.0.ebuild 1026 BLAKE2B 4ae4c8931e1c9acaf8dcb1ceb6f8026969e957c01cdd1cdd69c4484c4bf97da7bb9769c9a51e5e78f4a866c87a44400448e273726179aa25e3e4394d27d938a6 SHA512 ed79ce37edce20fbcc883320c7f3ef12d40597949f371df35782cd84afa94050f0bd9faf14ee6a137550ac6f12493bd919bba9ff21ebfe625c6133e4fcb5dd52
+MISC metadata.xml 350 BLAKE2B 91cfcda17c5879371a12e7faea70e149ffb7478408043f887f028ee862b7170269320f193746be9466cb7b4538898669e98a182b92731ece55ba97ac21d82465 SHA512 defb2af66dc0a90b83cc127144db7932659ce36beda28f59ea1fe693843fa3c41dd584f53b9ec6136ae2470aeab4ef191621e84862f97c33a736eae54d6c5a71
diff --git a/dev-ruby/classifier-reborn/classifier-reborn-2.2.0.ebuild b/dev-ruby/classifier-reborn/classifier-reborn-2.2.0.ebuild
new file mode 100644
index 000000000000..a4930c294bb5
--- /dev/null
+++ b/dev-ruby/classifier-reborn/classifier-reborn-2.2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Module to allow Bayesian and other types of classifications"
+HOMEPAGE="https://github.com/jekyll/classifier-reborn"
+SRC_URI="https://github.com/jekyll/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="gsl test"
+
+ruby_add_rdepend ">=dev-ruby/fast-stemmer-1.0.0
+ !!dev-ruby/classifier
+ gsl? ( dev-ruby/rb-gsl )"
+ruby_add_bdepend "test? ( dev-ruby/redis )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ if use !gsl; then
+ sed -e 's/$GSL = true/$GSL = false/'\
+ -e 's/vector_serialize/vector/'\
+ -i lib/${PN}/lsi.rb || die
+ fi
+ # Comment out broken test
+ #sed -i -e "/assert 'Normal',/s/^/#/" test/bayes/bayesian_test.rb || die
+
+ sed -i -e '/reporters/I s:^:#:' -e '/pry/ s:^:#:' test/test_helper.rb || die
+}
diff --git a/dev-ruby/classifier-reborn/metadata.xml b/dev-ruby/classifier-reborn/metadata.xml
new file mode 100644
index 000000000000..89e88426f8ab
--- /dev/null
+++ b/dev-ruby/classifier-reborn/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jekyll/classifier-reborn</remote-id>
+ </upstream>
+</pkgmetadata>