summaryrefslogtreecommitdiff
path: root/dev-ruby/coderay
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /dev-ruby/coderay
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'dev-ruby/coderay')
-rw-r--r--dev-ruby/coderay/Manifest2
-rw-r--r--dev-ruby/coderay/coderay-1.1.3-r1.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/coderay/Manifest b/dev-ruby/coderay/Manifest
index 3cd25ca0bfcc..8688d9ce105b 100644
--- a/dev-ruby/coderay/Manifest
+++ b/dev-ruby/coderay/Manifest
@@ -1,3 +1,5 @@
DIST coderay-1.1.2.tar.gz 220645 BLAKE2B 85405da2b148ae23573abf2c3fcf94a643024756308e83c4cecf0a5edae2fedc4ca7c7bdf8fb5936310f6699ca8f06f91cceb475e00511a54af0a96dd517c234 SHA512 cfce5e9f0a0d988e7920912e064ecbef3b54200a08ca2e07453452edd7f382a1eb9292bc566e069f5d1b784033e816f13d9ddfb39520e8e44a8d1e898aa33591
+DIST coderay-1.1.3.tar.gz 229139 BLAKE2B a900cc5fbac950f66814d9300876d6a273b296d07139297d5344d26c5710d23c37761e5743ef972f523afa20fa663f239c03d9d2ad47232b77e53fe5053736f0 SHA512 a5208965e8dbad53d179fdc1c57df59ba4e13522a1a57c371ccd3f9369408a1c7d878867df48b201a1d590b46ef0f9bada3f3e7810866f17d244b5b370aba3fb
EBUILD coderay-1.1.2.ebuild 1359 BLAKE2B f3a61690a53eb8a154173e73f1b3e75e417b56284f9a52e7308934d8bcbb44826378f2a736c9c8204a1ebdc7db86dacbc6d7ea1cc6fa7bb9d52de187a6b18076 SHA512 94df2b72f6f343630d3cf10176a0f30395f77cb8d2b124b0abc6b96c9b64daef5b0b9ec91cc21ba4857fa2e4388aa1ba12091855f80e24a5def6cbe66878c45b
+EBUILD coderay-1.1.3-r1.ebuild 1424 BLAKE2B 9f1f584d767d530732e5cc5a1f5f9d4feae1ba3deebc251ab47c21665e2bf6db78816432f409bff6d14e490f17645021dcdd281016120b5c95981135cfd5a5ef SHA512 10c64b1169844ad146b86bbc962075a53daef1c14ec06daf1929db5aa54fc7746d7f3d86817dbb56de4d9481cd976b0d67ebebc1f2f03b33c29ed78cb9c141b7
MISC metadata.xml 342 BLAKE2B b907829065b996e9bf467150216ce92b7fa4bedef8dbe9b9d79a1ba6831c706c312ce0d1cbb418df6c5b43dad59509c132187637025d4c49e9b29e21fa68a107 SHA512 13f33c6d77b3297dab6c125c2ebc9a1f7584dd5374e7f13d416d5a80ffe04e39ecdddd93de30fceed22e110e1c68e4b853fdd5b6ab5ec4d254c05b17f624ca4f
diff --git a/dev-ruby/coderay/coderay-1.1.3-r1.ebuild b/dev-ruby/coderay/coderay-1.1.3-r1.ebuild
new file mode 100644
index 000000000000..cf223d7b17de
--- /dev/null
+++ b/dev-ruby/coderay/coderay-1.1.3-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+# The test target also contains test:exe but that requires
+# shoulda-context which we do not have packaged yet.
+RUBY_FAKEGEM_TASK_TEST="test:functional test:units"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="Changes-pre-1.0.textile Changes.textile FOLDERS README_INDEX.rdoc README.markdown"
+
+RUBY_FAKEGEM_GEMSPEC="coderay.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby library for syntax highlighting"
+HOMEPAGE="http://coderay.rubychan.de/"
+SRC_URI="https://github.com/rubychan/coderay/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# Redcloth is an optional but automagically tested dependency. This
+# requires redcloth-4.2.2. We don't depend on this version to make
+# bootstrapping rspec with new versions easier, since redcloth depends
+# on rake-compiler.
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ sed -i -e '/git ls-files/ s:^:#:' -e 's/.rc.*"/"/' coderay.gemspec || die
+
+ # Fix failing tests for lazy evaluation in ruby26
+ sed -i -e 's/\.filter$/.filter.to_a/' test/unit/filter.rb || die
+}