summaryrefslogtreecommitdiff
path: root/dev-ruby/coercible/coercible-1.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-ruby/coercible/coercible-1.0.1.ebuild
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-ruby/coercible/coercible-1.0.1.ebuild')
-rw-r--r--dev-ruby/coercible/coercible-1.0.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/coercible/coercible-1.0.1.ebuild b/dev-ruby/coercible/coercible-1.0.1.ebuild
new file mode 100644
index 000000000000..1d0c60f226ef
--- /dev/null
+++ b/dev-ruby/coercible/coercible-1.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="README.md Changelog.md"
+RUBY_FAKEGEM_GEMSPEC="coercible.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+COMMIT=c076869838531abb5783280da108aa3cbddbd61a
+
+inherit ruby-fakegem
+
+DESCRIPTION="Powerful, flexible and configurable coercion library"
+HOMEPAGE="https://github.com/solnic/coercible https://rubygems.org/gems/coercible"
+SRC_URI="https://github.com/solnic/coercible/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+RUBY_S="${PN}-${COMMIT}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/descendants_tracker-0.0.1
+ <dev-ruby/descendants_tracker-0.1"
+
+ruby_add_bdepend "test? ( dev-ruby/rspec-its )"
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files/find * -print/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}