summaryrefslogtreecommitdiff
path: root/dev-ruby/colorize/colorize-0.8.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/colorize/colorize-0.8.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/colorize/colorize-0.8.1.ebuild')
-rw-r--r--dev-ruby/colorize/colorize-0.8.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/colorize/colorize-0.8.1.ebuild b/dev-ruby/colorize/colorize-0.8.1.ebuild
new file mode 100644
index 000000000000..31f2ac329f8e
--- /dev/null
+++ b/dev-ruby/colorize/colorize-0.8.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Adds methods to set color, background color and text effect on console easier"
+HOMEPAGE="https://github.com/fazibear/colorize"
+LICENSE="GPL-2+"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Cc]ode[Cc]limate/d" test/test_colorize.rb || die
+}
+
+each_ruby_test() {
+ cd test || die
+ ${RUBY} test_colorize.rb || die
+}