summaryrefslogtreecommitdiff
path: root/dev-ruby/date_validator/date_validator-0.9.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-ruby/date_validator/date_validator-0.9.0.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-ruby/date_validator/date_validator-0.9.0.ebuild')
-rw-r--r--dev-ruby/date_validator/date_validator-0.9.0.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-ruby/date_validator/date_validator-0.9.0.ebuild b/dev-ruby/date_validator/date_validator-0.9.0.ebuild
deleted file mode 100644
index 6a8969c17220..000000000000
--- a/dev-ruby/date_validator/date_validator-0.9.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_TASK_TEST="test"
-
-RUBY_FAKEGEM_TASK_DOC="docs"
-RUBY_FAKEGEM_EXTRADOC="Readme.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-# if ever needed
-#GITHUB_USER="codegram"
-#GITHUB_PROJECT="${PN}"
-#RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Simple, ORM agnostic, Ruby 1.9 compatible date validator for Rails 3"
-HOMEPAGE="https://github.com/codegram/date_validator"
-
-LICENSE="MIT"
-SLOT="3"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/activemodel-3.0:*
-"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/minitest
- >=dev-ruby/tzinfo-0.3
- >=dev-ruby/activesupport-3.0
- )
- doc? ( dev-ruby/yard )"
-
-all_ruby_prepare() {
- sed -i \
- -e '/git ls-files/d' \
- ${RUBY_FAKEGEM_GEMSPEC} || die
- sed -i \
- -e '/[Bb]undler/s/^/#/' Rakefile || die
- # Fix tests
- sed -i -e "1irequire 'active_support'" test/test_helper.rb || die
-}