summaryrefslogtreecommitdiff
path: root/dev-ruby/docile/docile-1.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-16 17:34:21 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-16 17:34:21 +0000
commit02e2208f46f4e2c00fb9743cbc47350bdd233bfa (patch)
tree132dd60828854db4f65f30f9230f43d9602507ff /dev-ruby/docile/docile-1.2.0.ebuild
parent8be70107efbb417f839292165ee39d07a062046f (diff)
gentoo resync : 16.01.2018
Diffstat (limited to 'dev-ruby/docile/docile-1.2.0.ebuild')
-rw-r--r--dev-ruby/docile/docile-1.2.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/docile/docile-1.2.0.ebuild b/dev-ruby/docile/docile-1.2.0.ebuild
new file mode 100644
index 000000000000..e38d1a5e24d2
--- /dev/null
+++ b/dev-ruby/docile/docile-1.2.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md HISTORY.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Turns any Ruby object into a DSL"
+HOMEPAGE="https://ms-ati.github.io/docile/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/require \"github\/markup\"/d' Rakefile || die
+ sed -i -e '/^unless on/,/^end/ s:^:#:' spec/spec_helper.rb || die
+}