summaryrefslogtreecommitdiff
path: root/dev-ruby/fakefs/fakefs-0.12.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-02 10:47:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-02 10:47:13 +0100
commit6c14fa2586d9e9c4427b5f727dc6c8ab77587cec (patch)
tree401ffbc2ade49ce18f6182969ec5fb697a57ce48 /dev-ruby/fakefs/fakefs-0.12.0.ebuild
parentd4bd6695641f6d2ec7ff8681913d304e995902f5 (diff)
gentoo resync : 02.06.2018
Diffstat (limited to 'dev-ruby/fakefs/fakefs-0.12.0.ebuild')
-rw-r--r--dev-ruby/fakefs/fakefs-0.12.0.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-ruby/fakefs/fakefs-0.12.0.ebuild b/dev-ruby/fakefs/fakefs-0.12.0.ebuild
deleted file mode 100644
index 738412468a2b..000000000000
--- a/dev-ruby/fakefs/fakefs-0.12.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_RECIPE_TEST="none"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="CONTRIBUTORS README.md"
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="A fake filesystem. Use it in your tests"
-HOMEPAGE="https://github.com/defunkt/fakefs"
-SRC_URI="https://github.com/defunkt/fakefs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_bdepend "
- test? (
- >=dev-ruby/rspec-3.1:3
- >=dev-ruby/minitest-5.5
- )"
-
-all_ruby_prepare() {
- # Remove bundler
- rm Gemfile || die
-
- # Avoid unneeded minitest-rg dependency.
- sed -i -e '1igem "minitest", "~>5.5"' \
- -e '/bundler/ s:^:#:' \
- -e '/minitest\/rg/ s:^:#:' test/test_helper.rb || die
-}
-
-each_ruby_test() {
- RSPEC_VERSION=3 ruby-ng_rspec
- ${RUBY} -Ilib:.:test -e 'Dir["test/**/*_test.rb"].each{|f| require f}' || die
-}