summaryrefslogtreecommitdiff
path: root/dev-ruby/faraday-follow_redirects
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-09 10:33:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-09 10:33:02 +0100
commit6440e1dd038e7df4f9df7dd5127d3b1c6f39034e (patch)
tree122c8899fbcce481ff7c1deb35c872f0236affa9 /dev-ruby/faraday-follow_redirects
parente7bc5cacb1abeb6806d255e2a817ab4dcb5f52b8 (diff)
gentoo auto-resync : 09:09:2023 - 10:33:01
Diffstat (limited to 'dev-ruby/faraday-follow_redirects')
-rw-r--r--dev-ruby/faraday-follow_redirects/Manifest3
-rw-r--r--dev-ruby/faraday-follow_redirects/faraday-follow_redirects-0.3.0.ebuild33
-rw-r--r--dev-ruby/faraday-follow_redirects/metadata.xml11
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-ruby/faraday-follow_redirects/Manifest b/dev-ruby/faraday-follow_redirects/Manifest
new file mode 100644
index 000000000000..5d20f553dde7
--- /dev/null
+++ b/dev-ruby/faraday-follow_redirects/Manifest
@@ -0,0 +1,3 @@
+DIST faraday-follow_redirects-0.3.0.tar.gz 9884 BLAKE2B 463cfb9e797f21355fea5318f0a647936194b671828e55c6ad6dff1c3e853b15ed0facac28e2f59c0cccf8db5d9f11f3bd66c1c877d9a9538d5deea832c4d3d2 SHA512 357b9618f203749f806b7882b39dfd1b90a403c9a76734f4d3ae59ef2a70430254e616be66fb5a0ec74e770e2ee9df6e0f805b00f70a6f99de12ff70fa4d2bda
+EBUILD faraday-follow_redirects-0.3.0.ebuild 833 BLAKE2B db194006e156c72e2281b47abef6a5045be29893bbef78a0cfd55491c4cf50ed94bdd7008d65233d2db5cbe676fd0ba51f4e67bb954d4e3ac6029a5e195efcc5 SHA512 041fb0943ab383613105f290c7b2e34c13eea7e5833a086043f67342efdf401338f209213ae1699ef8cd5e1dbf8822a33cae2b1a9ea545cafdff72180c3d7e7b
+MISC metadata.xml 357 BLAKE2B e193eef844776fcdd109a71f7cfbdd86c37b0370df4c2a99342d3fa941ce5112363ca33b62eb84f44bf894398546333da4a028b7cba4b4ce03f248f33efa26d6 SHA512 e7b067fd887074207600f88d36b939c949a40b8c63a990c46f9bede03b1e34aa8eeeb40b773b1cf87a8c07f7e98af6d5bcc97cbb050f1a0c3f2a8d955ede581e
diff --git a/dev-ruby/faraday-follow_redirects/faraday-follow_redirects-0.3.0.ebuild b/dev-ruby/faraday-follow_redirects/faraday-follow_redirects-0.3.0.ebuild
new file mode 100644
index 000000000000..78e79967c84a
--- /dev/null
+++ b/dev-ruby/faraday-follow_redirects/faraday-follow_redirects-0.3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Perform multipart-post requests using Faraday"
+HOMEPAGE="https://github.com/tisba/faraday-follow-redirects"
+SRC_URI="https://github.com/tisba/faraday-follow-redirects/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="faraday-follow-redirects-${PV}"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_rdepend "|| ( dev-ruby/faraday:2 dev-ruby/faraday:1 )"
+
+ruby_add_bdepend "test? ( dev-ruby/webmock )"
+
+all_ruby_prepare() {
+ sed -i -e "s:_relative ':'./:" ${RUBY_FAKEGEM_GEMSPEC} || die
+}
diff --git a/dev-ruby/faraday-follow_redirects/metadata.xml b/dev-ruby/faraday-follow_redirects/metadata.xml
new file mode 100644
index 000000000000..42a21a64fc14
--- /dev/null
+++ b/dev-ruby/faraday-follow_redirects/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tisba/faraday-follow-redirects</remote-id>
+ </upstream>
+</pkgmetadata>