summaryrefslogtreecommitdiff
path: root/dev-ruby/fcgi/fcgi-0.9.2.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/fcgi/fcgi-0.9.2.1-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/fcgi/fcgi-0.9.2.1-r1.ebuild')
-rw-r--r--dev-ruby/fcgi/fcgi-0.9.2.1-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/fcgi/fcgi-0.9.2.1-r1.ebuild b/dev-ruby/fcgi/fcgi-0.9.2.1-r1.ebuild
new file mode 100644
index 000000000000..704b0eb1c9ad
--- /dev/null
+++ b/dev-ruby/fcgi/fcgi-0.9.2.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc README.signals"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="FastCGI library for Ruby"
+HOMEPAGE="https://github.com/alphallc/ruby-fcgi-ng"
+
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+LICENSE="Ruby"
+
+DEPEND+=" dev-libs/fcgi"
+RDEPEND+=" dev-libs/fcgi"
+
+IUSE=""
+SLOT="0"
+
+each_ruby_configure() {
+ ${RUBY} -C ext/fcgi extconf.rb || die "extconf failed"
+}
+
+each_ruby_compile() {
+ emake V=1 -C ext/fcgi
+ cp ext/fcgi/fcgi$(get_modname) lib || die
+}