summaryrefslogtreecommitdiff
path: root/dev-ruby/fileutils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-08 10:24:46 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-08 10:24:46 +0000
commit9263a8dda30106335f556e7f5936f5607db6f92c (patch)
tree59614d42ee7ac6187fd0c542956f2aa89c39f6e9 /dev-ruby/fileutils
parentd8ae0501eb6c157339ede48ca34513d27470e1dc (diff)
gentoo auto-resync : 08:11:2023 - 10:24:46
Diffstat (limited to 'dev-ruby/fileutils')
-rw-r--r--dev-ruby/fileutils/Manifest2
-rw-r--r--dev-ruby/fileutils/fileutils-1.7.2.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/fileutils/Manifest b/dev-ruby/fileutils/Manifest
index 6a2cb5b48d80..993b14079ef0 100644
--- a/dev-ruby/fileutils/Manifest
+++ b/dev-ruby/fileutils/Manifest
@@ -1,3 +1,5 @@
DIST fileutils-1.7.1.tar.gz 40841 BLAKE2B a93a9a3357302ac420a4eec3349207d38e2b9e88cf2eb839c769c9219b3b1afa1b106dbc83e55ca907971909ae678189bc25eb7615243bebd20cab4c611a29d6 SHA512 d4aa814959a8c609aa0cf39755172db8c6efcd320cce41ac861a075c960a1dc35a1a3e5a4bea00d7051196e7f69043b4f7ef8f30ef31b8e943f4f10f926a0036
+DIST fileutils-1.7.2.tar.gz 30020 BLAKE2B 6b50a1cbeb725fbe423f602aa024169fd480dabb937a8479421a4ea86bedf90b45fdae01b4ffc46480d93e3b73805eed1bab482c41d5de69fec9ebcd7348c38e SHA512 85732efe0dfb53bbf273030f2389c82a81eca38d3f5aa77bc8bde56c0b082a247573d2adf56320c7a680ef7630c88f525baaf7b52ba3a2b0adab899d1b242f46
EBUILD fileutils-1.7.1.ebuild 836 BLAKE2B 9dd97e105449aa6502b847ee175df4e54b8bebd82b69e8514b2816672d3062492ba4c10e353ac34b088a5a79cd33ac7bc25147eb8948cadee2d50d54004deda4 SHA512 56a7b3e52fba8479118d6beba8709b6bdc5432945f55773e9083bdcabb722d8907e3769df827790438a6cfa58458f44e04aa8f4a8c0999098dd0ab5193c52a0c
+EBUILD fileutils-1.7.2.ebuild 907 BLAKE2B e762bf11ea41fb9ff02960a86e39a146ae03c51e102bc6dcaf6b37ef707621ff5a269e3ee8d24070d96adc06febbccf8363de6db66f201419bde12633bad2f3d SHA512 16ca8f62cf94d7e37d70048c3b18f2ed0fdfa910c55bd06414b0fc940eb88aa1e2a3287b36c6def5f6c483937bd82defd0b0d3b3537ff8959557739351b220e6
MISC metadata.xml 341 BLAKE2B fd6d101aece04f1d559ac8cfce2e2768a10d97e78d96304e205ae7ea16ab16ae79d6fa9f0eff00ede06d07c032c56dea9b22157c0b94cf7410be1b09f5ac061a SHA512 dbdd5c0b1672905cb1d7a537da82cc9b1bc7fdc84c809a7f3ed0adb416c9c30a36c5fb9ccb60fbfd1702e776f55377981dbfb25668928cd193de05cc14f848db
diff --git a/dev-ruby/fileutils/fileutils-1.7.2.ebuild b/dev-ruby/fileutils/fileutils-1.7.2.ebuild
new file mode 100644
index 000000000000..b383f51225f2
--- /dev/null
+++ b/dev-ruby/fileutils/fileutils-1.7.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="fileutils.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Several file utility methods for copying, moving, removing, etc"
+HOMEPAGE="https://github.com/ruby/fileutils"
+SRC_URI="https://github.com/ruby/fileutils/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit dev-ruby/test-unit-ruby-core )"
+
+all_ruby_prepare() {
+ sed -e 's/__dir__/"."/' \
+ -e 's/__FILE__/"'${RUBY_FAKEGEM_GEMSPEC}'"/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}