summaryrefslogtreecommitdiff
path: root/dev-ruby/haml/haml-6.2.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-24 13:37:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-24 13:37:40 +0000
commitba4938837d52c0aff763d8acdc03ce103dd3ff82 (patch)
tree377739d379f8040dc456a89b2347a8f2a83830c8 /dev-ruby/haml/haml-6.2.3.ebuild
parent3e3aa158fd100df495010eed7915f012d5c9bcaa (diff)
gentoo auto-resync : 24:12:2023 - 13:37:40
Diffstat (limited to 'dev-ruby/haml/haml-6.2.3.ebuild')
-rw-r--r--dev-ruby/haml/haml-6.2.3.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-ruby/haml/haml-6.2.3.ebuild b/dev-ruby/haml/haml-6.2.3.ebuild
index a4ac5c0cb899..bf2b489c8e40 100644
--- a/dev-ruby/haml/haml-6.2.3.ebuild
+++ b/dev-ruby/haml/haml-6.2.3.ebuild
@@ -19,7 +19,7 @@ SRC_URI="https://github.com/haml/haml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="$(ver_cut 1)"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+KEYWORDS="~amd64 ~arm arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
IUSE="doc test"
@@ -49,6 +49,11 @@ all_ruby_prepare() {
test/test_helper.rb || die
# Remove tests that fails when RedCloth is available
rm -f test/haml/filters/markdown_test.rb || die
+ # Remove tests that require coffee-script (does not work with x32
+ # and coffee-script is obsolete anyway).
+ rm -f test/haml/filters/coffee_test.rb || die
+ sed -e '/describe.*coffee filter/,/^ end/ s:^:#:' \
+ -i test/haml/line_number_test.rb || die
}
each_ruby_test() {