summaryrefslogtreecommitdiff
path: root/dev-ruby/hashdiff/hashdiff-1.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /dev-ruby/hashdiff/hashdiff-1.0.1.ebuild
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'dev-ruby/hashdiff/hashdiff-1.0.1.ebuild')
-rw-r--r--dev-ruby/hashdiff/hashdiff-1.0.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/hashdiff/hashdiff-1.0.1.ebuild b/dev-ruby/hashdiff/hashdiff-1.0.1.ebuild
new file mode 100644
index 000000000000..1c569e84d3b3
--- /dev/null
+++ b/dev-ruby/hashdiff/hashdiff-1.0.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="changelog.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple Hash extension to make working with nested hashes easier"
+HOMEPAGE="https://github.com/liufengyun/hashdiff"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
+}