summaryrefslogtreecommitdiff
path: root/dev-ruby/http-accept/http-accept-1.7.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-04 16:08:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-04 16:08:55 +0100
commita4a6bfb13b5393e584d42ef735796caa2a87c831 (patch)
tree2c704fc127dfea99d1f7b5b99671ec17af05dddf /dev-ruby/http-accept/http-accept-1.7.0-r1.ebuild
parentfea4a05eed382195ccf0fd9536eb165d60bd2c5f (diff)
gentoo auto-resync : 04:07:2023 - 16:08:54
Diffstat (limited to 'dev-ruby/http-accept/http-accept-1.7.0-r1.ebuild')
-rw-r--r--dev-ruby/http-accept/http-accept-1.7.0-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/http-accept/http-accept-1.7.0-r1.ebuild b/dev-ruby/http-accept/http-accept-1.7.0-r1.ebuild
new file mode 100644
index 000000000000..9943889c519f
--- /dev/null
+++ b/dev-ruby/http-accept/http-accept-1.7.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="http-accept.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Parse Accept and Accept-Language HTTP headers"
+HOMEPAGE="https://github.com/socketry/http-accept"
+SRC_URI="https://github.com/socketry/http-accept/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~arm64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}