summaryrefslogtreecommitdiff
path: root/dev-ruby/http-cookie
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-15 12:22:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-15 12:22:30 +0100
commit3ad1879f00b279af69d6b9cd3ef97a2a7496d734 (patch)
tree497e5c46d6f6695b96866bc46abe1a2470a880b5 /dev-ruby/http-cookie
parent792e307954fd3b5b12c968741d76ea7cfe5206e4 (diff)
gentoo auto-resync : 15:08:2024 - 12:22:30
Diffstat (limited to 'dev-ruby/http-cookie')
-rw-r--r--dev-ruby/http-cookie/Manifest2
-rw-r--r--dev-ruby/http-cookie/http-cookie-1.0.7.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/http-cookie/Manifest b/dev-ruby/http-cookie/Manifest
index 6961da0a26aa..787c0cc638f6 100644
--- a/dev-ruby/http-cookie/Manifest
+++ b/dev-ruby/http-cookie/Manifest
@@ -1,5 +1,7 @@
DIST http-cookie-1.0.5.gem 39424 BLAKE2B 569a0d18c962be378f3974b400ddf2289c72490b2b93619fcd83ed6c00bbf5def76239c52163dc6231060792abf3a19988285a6cd28f158ff7339252da912e61 SHA512 d530d64b5c2fc3757a6de03384fe768317e24a523d4a4215f5bcc6b5bca9e7b94eeaad1e52fbb67548396b7b2ca7c9d8b68ea7b99109e24770fcf34c950469ef
DIST http-cookie-1.0.6.gem 40448 BLAKE2B 428cd8aef9d08ff86486c1dab10f75e2cf0aa614eda598a95e35598f945a41cc35cf7a871b4b6b56f01435790c7995d1cb83c2fff46463282d66f0e1cd8a0883 SHA512 088949816b70c3eea5464b492cb067d1d1cea8608ba8ad791876b5a33cc57c95b036420e3e9872a40e35c84168a37ab6b4615a049ea98b04588000cdf594bc5f
+DIST http-cookie-1.0.7.gem 40448 BLAKE2B 36ce6daabaa5e2385fbe5f3db4b18cef8c304ac23f2200978d56ef726c6ed2f5bab09bd779c885bd23207130101b0143833696753e00c71f3504c2696fe15d17 SHA512 ed83e492d60f5af50d184e590ae3bb85be1cc34019619ac8053e0a8249deea239c66076b70b48b2db4066f18fcc478fee5bca118e7ee697b8bbb5f5985da7124
EBUILD http-cookie-1.0.5-r1.ebuild 766 BLAKE2B 63ae5fdf150dd535139ca190a422db08bb2843ed7e446386b085f2e9b50c57f3b0dee766b15a1f76c077fdca6a74f80ba2b00fc23296230e823c9fd821c37426 SHA512 d889f2f38d99cd8605583fd7d79b35cbeecaa700409577ab1cd5b5fbfd0de4e122d512ab132c21d054f72ba23e9c78a2fbb993a53fd61e966459db99ba085463
EBUILD http-cookie-1.0.6.ebuild 816 BLAKE2B a921e373a9cde65fdd089f236539f73a1efb614c95db2e2580587c235973581f787284b48d34b72bcf916de680dbe8908efd3ae8a4b048c50e8801913d4d397f SHA512 cf84d5c7ae31cf8f1aa51c6a74929dd0e8857386b6f5f51c65ac847b64910b85c66f022e7803be9f45458a19a56a066d615e734c26a80b7c284f00cf795f542d
+EBUILD http-cookie-1.0.7.ebuild 765 BLAKE2B b267b8178ca5f4e8ad69cfb9e813ccf7b4bca859fb7267e10021d6aea8ebed02eb3af43e0fab058041b1424648f191e75ef965d2444a3e7012bcc8d3fd8123c7 SHA512 8af750bb5233479239edbf888e54d14879022535796d604c3bf985d6e95b4af03d9d2a8565911a1b916f2b4df3bae28993598ab125ab6556aea45ae6b8cb2e98
MISC metadata.xml 352 BLAKE2B 0e1cc1e4cc97d4d773c64a068d2f7246c863fae1c17504f83275d1ab15e59a9bc6535c22fdf0c02d89d778079d100b74e29170b0fbe6fc1ad5464e221751a56d SHA512 821e08b75914f51a4a341149db588c8e3b17fc401a14de9abd44918b9f6bf88bc1d9c76b460a10c1b312669db478759aab90d0bb08bc04129bc8c964e7b3a314
diff --git a/dev-ruby/http-cookie/http-cookie-1.0.7.ebuild b/dev-ruby/http-cookie/http-cookie-1.0.7.ebuild
new file mode 100644
index 000000000000..047a9505786e
--- /dev/null
+++ b/dev-ruby/http-cookie/http-cookie-1.0.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby library to handle HTTP cookies"
+HOMEPAGE="https://github.com/sparklemotion/http-cookie"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# See https://github.com/sparklemotion/http-cookie/issues/16 for dropping domain_name
+ruby_add_rdepend ">=dev-ruby/domain_name-0.5:0"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/d" -e "/bundler/d" Rakefile || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/test_http_cookie.rb || die
+ ${RUBY} -Ilib test/test_http_cookie_jar.rb || die
+}