summaryrefslogtreecommitdiff
path: root/dev-ruby/http-cookie
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/http-cookie
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/http-cookie')
-rw-r--r--dev-ruby/http-cookie/Manifest3
-rw-r--r--dev-ruby/http-cookie/http-cookie-1.0.3.ebuild29
-rw-r--r--dev-ruby/http-cookie/metadata.xml11
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/http-cookie/Manifest b/dev-ruby/http-cookie/Manifest
new file mode 100644
index 000000000000..07ade3a11560
--- /dev/null
+++ b/dev-ruby/http-cookie/Manifest
@@ -0,0 +1,3 @@
+DIST http-cookie-1.0.3.gem 38400 BLAKE2B 6b7292b2a5d7c37b6769cdd38f01d8cf78aa9557b4a204d736dffeae5d31768c57ac58f00577df78252f9a8bdb12a7faecf5e1be64c8ee29aaf67cc9307d0a35 SHA512 43ac1218e98dd47ee22e33e72e20bc5b55f65e60aadd417641f8a4221eba88995d418c7738a4c35dfba132e05c0c4b0df2b2bedd56c22e82c062d1f03de0052f
+EBUILD http-cookie-1.0.3.ebuild 702 BLAKE2B c6e437e218957cc01357d3983ab0e1b24b3dd72821ce920fe772645f0942f90437323fc5cc4fb7d515b56feefb952f36e7a2deaacacba705c3046427a722eea8 SHA512 8699a40ebd602e93f16c06de1937c03bba92ebf99f3c87dfd1cfd1db914b9c38ada31b92b1bb5a0fee596df808cdf6c1ffc571be2b5ad52cf7643ce061e12578
+MISC metadata.xml 351 BLAKE2B 926eb407cb14931a24791340dd7b529823fcf35a7ed86f5b9f13a6238db82d71f71775f4820b07056d486c299afb97b23acb0f6419fbbeab69feb4b49e667950 SHA512 e9ad64c767ea22fcd169c61f71dfd8b292592e6efcb27273df9d90584e39897434d52f974037694f346d8388564fa8b8550f2da1ac11ef4e4a2e450e11701efc
diff --git a/dev-ruby/http-cookie/http-cookie-1.0.3.ebuild b/dev-ruby/http-cookie/http-cookie-1.0.3.ebuild
new file mode 100644
index 000000000000..eed00c01bec8
--- /dev/null
+++ b/dev-ruby/http-cookie/http-cookie-1.0.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby library to handle HTTP cookies"
+HOMEPAGE="https://github.com/sparklemotion/http-cookie"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ppc ppc64 sparc x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/domain_name-0.5:0"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/d" -e "/bundler/d" Rakefile || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/test_http_cookie.rb || die
+ ${RUBY} -Ilib test/test_http_cookie_jar.rb || die
+}
diff --git a/dev-ruby/http-cookie/metadata.xml b/dev-ruby/http-cookie/metadata.xml
new file mode 100644
index 000000000000..89106073709d
--- /dev/null
+++ b/dev-ruby/http-cookie/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">sparklemotion/http-cookie</remote-id>
+ </upstream>
+</pkgmetadata>