summaryrefslogtreecommitdiff
path: root/dev-ruby/httpclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-23 11:40:30 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-23 11:40:30 +0000
commitedca36e835d0d4e929c1dd3e9688954ae0aa191a (patch)
treec60f9dd076d4eff037c8ad746de4bf5d48e55b08 /dev-ruby/httpclient
parent914bc7f07098ac3918913e4c83951a9cbba5a949 (diff)
gentoo auto-resync : 23:02:2024 - 11:40:30
Diffstat (limited to 'dev-ruby/httpclient')
-rw-r--r--dev-ruby/httpclient/Manifest1
-rw-r--r--dev-ruby/httpclient/httpclient-2.8.3-r2.ebuild78
2 files changed, 0 insertions, 79 deletions
diff --git a/dev-ruby/httpclient/Manifest b/dev-ruby/httpclient/Manifest
index a7321a880c58..949ed3d6f6c4 100644
--- a/dev-ruby/httpclient/Manifest
+++ b/dev-ruby/httpclient/Manifest
@@ -1,4 +1,3 @@
DIST httpclient-2.8.3.tgz 464624 BLAKE2B ce8ed523a24acce219027a4f1985caf2b4dae29bdba038ca2397e5f4d4b36c90b35cedfb62faa7faf426c3ce8589906df7832968c81b64bc9100eff6f4fe9745 SHA512 b65b5adb97af069d7ff6b6f4cccd6a42c6d9c88b797e9495768fe1f36a6bd93defe50190edc201de5e39c4e306ba0bd17a8ff2f8eba4d636dacafa06c172967d
-EBUILD httpclient-2.8.3-r2.ebuild 2742 BLAKE2B 9d69325eb752210c9869056542349efed823002b19255f0922d9547b1537b68ebc35787a0b05fd8fc2b474bcf60b20a0904e7f3bf57be46118168fa386d615e1 SHA512 168a1f236b66812c31cb3a04f2291b4377d92147215998e557659dbaa7865317130069437711b6e9df9d0a792d10cec7dd2e9b7978d72f7ec1428e14bd28064d
EBUILD httpclient-2.8.3-r3.ebuild 2613 BLAKE2B c82341804c5144456641d89a2c42056a10adb5fb70138c03b8364225053d306ceddbc4d15837dce57f2860cd2ba0e86cdf31f48f012c5ceac3fd4e1c8856d1cc SHA512 38e6b371f7de30bdc61c338ce7edef38422eda513875a3cb51c3e3743d6fd4b35971505323620f808816f05255621ff9ca8504da34860d30b95206cdd26a0923
MISC metadata.xml 342 BLAKE2B 357371edae972dc4bf17bef8a0ddf752bd81a3936a4ba6cc83ec7a253346e3d236bb0930fc71f14c1c42a486f3202bcd08352260aef38676f57b31f852dcca27 SHA512 3c3e6861463a129c5679658a044b956f1d8a4ad086c5fc77029037ad88b391af06cfbe26127127ae0b909d602c9a3b02929c48d7a26059ebd29e06c394d7b4c4
diff --git a/dev-ruby/httpclient/httpclient-2.8.3-r2.ebuild b/dev-ruby/httpclient/httpclient-2.8.3-r2.ebuild
deleted file mode 100644
index dce9f71beaea..000000000000
--- a/dev-ruby/httpclient/httpclient-2.8.3-r2.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-USE_RUBY="ruby27 ruby30 ruby31"
-
-RUBY_FAKEGEM_TASK_TEST="-Ilib test"
-RUBY_FAKEGEM_TASK_DOC="doc"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_GEMSPEC="httpclient.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="'httpclient' gives something like the functionality of libwww-perl (LWP) in Ruby"
-HOMEPAGE="https://github.com/nahi/httpclient"
-SRC_URI="https://github.com/nahi/httpclient/archive/v${PV}.tar.gz -> ${P}.tgz"
-
-LICENSE="|| ( Ruby Ruby-BSD BSD-2 )"
-SLOT="0"
-
-KEYWORDS="amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE=""
-
-ruby_add_rdepend "virtual/ruby-ssl"
-
-ruby_add_bdepend "doc? ( dev-ruby/rdoc )"
-ruby_add_bdepend "test? ( dev-ruby/test-unit dev-ruby/http-cookie )"
-
-all_ruby_prepare() {
- rm Gemfile || die
- sed -i -e '/[bB]undler/s:^:#:' Rakefile || die
-
- # Fix documentation task
- sed -i -e 's/README.txt/README.md/' Rakefile || die
-
- # Remove mandatory CI reports since we don't need this for testing.
- sed -i -e '/reporter/s:^:#:' Rakefile || die
-
- # Remove mandatory simplecov dependency
- sed -i -e '/[Ss]imple[Cc]ov/ s:^:#:' test/helper.rb || die
-
- # Comment out test requiring network access that makes assumptions
- # about the environment, bug 395155
- sed -i -e '/test_async_error/,/^ end/ s:^:#:' test/test_httpclient.rb || die
-
- # Skip tests using rack-ntlm which is not packaged. Weirdly these
- # only fail on jruby.
- rm test/test_auth.rb || die
-
- # Skip test failing due to hard-coded expired certificate
- sed -i -e '/test_verification_without_httpclient/,/^ end/ s:^:#:' test/test_ssl.rb || die
-
- # Skip test depending on obsolete and vulnerable SSLv3
- sed -i -e '/test_no_sslv3/,/^ end/ s:^:#:' test/test_ssl.rb || die
-
- # Do not use 11-year-old bundled certificates!
- # fix this copy so it doesn't fail tests
- ln -sf "${EPREFIX}"/etc/ssl/certs/ca-certificates.crt ./dist_key/cacerts.pem
- ln -sf "${EPREFIX}"/etc/ssl/certs/ca-certificates.crt ./lib/httpclient/cacert.pem
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib:test:. -e 'gem "test-unit"; Dir["test/test_*.rb"].each{|f| require f}' || die
-}
-
-each_ruby_install() {
- each_fakegem_install
- # Do not use 11-year-old bundled certificates!
- # fix this copy for production systems
- # do not ship the cacert1024.pem at all anymore, nobody should use RSA1024 certs!
- rm -f "${ED}/$(ruby_fakegem_gemsdir)/gems/${RUBY_FAKEGEM_NAME}-${RUBY_FAKEGEM_VERSION}/lib/httpclient/"{cacert.pem,cacert1024}.pem
- dosym -r /etc/ssl/certs/ca-certificates.crt $(ruby_fakegem_gemsdir)/gems/${RUBY_FAKEGEM_NAME}-${RUBY_FAKEGEM_VERSION}/lib/httpclient/cacert.pem
-}