summaryrefslogtreecommitdiff
path: root/dev-ruby/instance_storage/instance_storage-2.0.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-30 01:41:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-30 01:41:48 +0100
commit38c20fb51b0482ec1b2c2a34ed16227718eac4b2 (patch)
tree18555c0f1f2d21b225fb67bd5408127b8aaadef2 /dev-ruby/instance_storage/instance_storage-2.0.0-r1.ebuild
parent2831634aa8213b30f404da1f64644d94dc66a6d0 (diff)
gentoo auto-resync : 30:06:2023 - 01:41:48
Diffstat (limited to 'dev-ruby/instance_storage/instance_storage-2.0.0-r1.ebuild')
-rw-r--r--dev-ruby/instance_storage/instance_storage-2.0.0-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ruby/instance_storage/instance_storage-2.0.0-r1.ebuild b/dev-ruby/instance_storage/instance_storage-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..342cf1f29123
--- /dev/null
+++ b/dev-ruby/instance_storage/instance_storage-2.0.0-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+DESCRIPTION="Manage class instances with dictionary"
+HOMEPAGE="https://rubygems.org/gems/instance_storage/"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile test/instance_storage_test.rb || die
+}