summaryrefslogtreecommitdiff
path: root/dev-ruby/itextomml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/itextomml
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/itextomml')
-rw-r--r--dev-ruby/itextomml/Manifest5
-rw-r--r--dev-ruby/itextomml/itextomml-1.5.6.ebuild34
-rw-r--r--dev-ruby/itextomml/itextomml-1.5.7.ebuild34
-rw-r--r--dev-ruby/itextomml/metadata.xml8
4 files changed, 81 insertions, 0 deletions
diff --git a/dev-ruby/itextomml/Manifest b/dev-ruby/itextomml/Manifest
new file mode 100644
index 000000000000..1f443f803883
--- /dev/null
+++ b/dev-ruby/itextomml/Manifest
@@ -0,0 +1,5 @@
+DIST itextomml-1.5.6.gem 125440 BLAKE2B b0894d26d20e85454c310589509cb0eef371f3c9139450ce8dcd25fac6b83e831557e05ba54b449557422b23d59868ee75f022fe4ba1c205d32926f923986864 SHA512 b74f5a9ca4eb669fee547bdf729e456dfe07b8be4e9ac0d1b7c3ad5d4e99371ae7b5bde565e6472ab07bbcec2754d4ee628ba07a6a7e938ea8a55a6023c2f1fd
+DIST itextomml-1.5.7.gem 125440 BLAKE2B babdfdb7e81415a06875ba72a84da31f910bb0f634e2fd2ea724785b56d84b6d6ca7e544ddfe617a53c91a89314f0e0e8c2ac0f20f0cf8e26c11327f865e423b SHA512 65fbf03096695330e32ac9093e923ca50bb92a3b32a7657bea65e6abf51c7824fc8b650f564352c41d28e846cba62a60ffbd57ca14ad2587e3164e48d7d1043f
+EBUILD itextomml-1.5.6.ebuild 742 BLAKE2B a3b0c797eb53d82160e9fec01e2c2af41be577d5265cc69f2cdc0d3c25f3a61f3b5764213434f9f88d9b41cca9ef281435de017bbf01a7280a30d3e2efac8ffc SHA512 981eefe3909d3bb29cebc9751026f2d057372a802437ebea804d2a92a184913a1eef279a1a5f78ac1f447dd464ae2117efb08c774ddb3b141e3feb1dfa7e40ef
+EBUILD itextomml-1.5.7.ebuild 742 BLAKE2B a3b0c797eb53d82160e9fec01e2c2af41be577d5265cc69f2cdc0d3c25f3a61f3b5764213434f9f88d9b41cca9ef281435de017bbf01a7280a30d3e2efac8ffc SHA512 981eefe3909d3bb29cebc9751026f2d057372a802437ebea804d2a92a184913a1eef279a1a5f78ac1f447dd464ae2117efb08c774ddb3b141e3feb1dfa7e40ef
+MISC metadata.xml 257 BLAKE2B 6339b8ae3ef779011f34940b5af7faca341317790ee6752ad73cb83db463ddad10b25cacf16f73ce6d0fde976d916e2838e6209bdedfbe5ef6da285be302203d SHA512 d86ea11e509e5d031f82c4bb476a5974b85d812abe415e95799bdf34a308ade95e2f1cf35f6af84ae5acd0f67996b150c02712b75ab4f5a1ff4eef0ffb046d7e
diff --git a/dev-ruby/itextomml/itextomml-1.5.6.ebuild b/dev-ruby/itextomml/itextomml-1.5.6.ebuild
new file mode 100644
index 000000000000..8f5692eb0c80
--- /dev/null
+++ b/dev-ruby/itextomml/itextomml-1.5.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Native Ruby bindings to itex2MML, which converts itex equations to MathML"
+HOMEPAGE="https://golem.ph.utexas.edu/~distler/blog/itex2MML.html"
+
+LICENSE="|| ( GPL-2+ MPL-1.1 LGPL-2+ )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+#Tests don't fail here
+RESTRICT="test"
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext
+ cp ext/itex2MML$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} test/test_itextomml.rb || die
+}
diff --git a/dev-ruby/itextomml/itextomml-1.5.7.ebuild b/dev-ruby/itextomml/itextomml-1.5.7.ebuild
new file mode 100644
index 000000000000..8f5692eb0c80
--- /dev/null
+++ b/dev-ruby/itextomml/itextomml-1.5.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Native Ruby bindings to itex2MML, which converts itex equations to MathML"
+HOMEPAGE="https://golem.ph.utexas.edu/~distler/blog/itex2MML.html"
+
+LICENSE="|| ( GPL-2+ MPL-1.1 LGPL-2+ )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+#Tests don't fail here
+RESTRICT="test"
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext
+ cp ext/itex2MML$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} test/test_itextomml.rb || die
+}
diff --git a/dev-ruby/itextomml/metadata.xml b/dev-ruby/itextomml/metadata.xml
new file mode 100644
index 000000000000..3df5c34efc94
--- /dev/null
+++ b/dev-ruby/itextomml/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+</pkgmetadata>