summaryrefslogtreecommitdiff
path: root/dev-ruby/jwt/jwt-2.9.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-04-05 01:34:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2025-04-05 01:34:33 +0100
commit8bcae5a5a332db9dc28c20b7a5f28337d8335254 (patch)
treef5e955d5d9283743bda70a7d99a915db594b8a50 /dev-ruby/jwt/jwt-2.9.0.ebuild
parent74dcbf5a63cafe2678e2a397e1002dd691425200 (diff)
gentoo auto-resync : 05:04:2025 - 01:34:33HEADnextmaster
Diffstat (limited to 'dev-ruby/jwt/jwt-2.9.0.ebuild')
-rw-r--r--dev-ruby/jwt/jwt-2.9.0.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/dev-ruby/jwt/jwt-2.9.0.ebuild b/dev-ruby/jwt/jwt-2.9.0.ebuild
deleted file mode 100644
index 8b4de2060122..000000000000
--- a/dev-ruby/jwt/jwt-2.9.0.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby31 ruby32 ruby33"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_BINWRAP=""
-RUBY_FAKEGEM_GEMSPEC="ruby-jwt.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A Ruby implementation of JSON Web Token draft 06"
-HOMEPAGE="https://github.com/jwt/ruby-jwt"
-SRC_URI="https://github.com/jwt/ruby-jwt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="2"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
-IUSE="eddsa test"
-
-RUBY_S="ruby-jwt-${PV}"
-
-ruby_add_rdepend "dev-ruby/base64 eddsa? ( dev-ruby/rbnacl )"
-
-ruby_add_bdepend "test? ( dev-ruby/rbnacl )"
-
-all_ruby_prepare() {
- sed -i -e "/simplecov/ s:^:#:" \
- -e '/^SimpleCov.start/,/^end/ s:^:#:' \
- spec/spec_helper.rb || die
-
- sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
-}