summaryrefslogtreecommitdiff
path: root/dev-ruby/launchy/launchy-2.5.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-28 14:12:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-28 14:12:52 +0000
commitebadb1bcdd3c4fdd2e1a569a04d2cd8c5049b64d (patch)
tree261a9ff495381f4023c98dfb4ecd5cb195b5f346 /dev-ruby/launchy/launchy-2.5.2.ebuild
parent2666e9c75caf914c25a25329523c982df8512930 (diff)
gentoo auto-resync : 28:12:2022 - 14:12:52
Diffstat (limited to 'dev-ruby/launchy/launchy-2.5.2.ebuild')
-rw-r--r--dev-ruby/launchy/launchy-2.5.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/launchy/launchy-2.5.2.ebuild b/dev-ruby/launchy/launchy-2.5.2.ebuild
new file mode 100644
index 000000000000..3f14716ff67a
--- /dev/null
+++ b/dev-ruby/launchy/launchy-2.5.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="README.md HISTORY.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Helper class for launching cross-platform applications"
+HOMEPAGE="https://github.com/copiousfreetime/launchy"
+
+LICENSE="ISC"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/addressable-2.8"
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.0:5 )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Ss]implecov/d" spec/spec_helper.rb || die
+
+ # Avoid tests depending on the current user's desktop environment.
+ sed -e '/returns NotFound if it cannot determine/askip "gentoo"' \
+ -i spec/detect/nix_desktop_environment_spec.rb || die
+ sed -e '/asssumes we open a local file if we have an exception/askip "gentoo"' \
+ -i spec/launchy_spec.rb || die
+ sed -e "/'darwin'/ s:^:#:" \
+ -i spec/applications/browser_spec.rb || die
+}