summaryrefslogtreecommitdiff
path: root/dev-ruby/locale
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
commit53cba99042fa967e2a93da9f8db806fe2d035543 (patch)
tree9780d3b87dfc6bdebc6b7b7d15af1ecb813c6853 /dev-ruby/locale
parent71deace00d1a2b091313fe137ab7092418c6f87c (diff)
gentoo resync : 17.02.2020
Diffstat (limited to 'dev-ruby/locale')
-rw-r--r--dev-ruby/locale/Manifest4
-rw-r--r--dev-ruby/locale/locale-2.1.2-r1.ebuild2
-rw-r--r--dev-ruby/locale/locale-2.1.3.ebuild51
3 files changed, 55 insertions, 2 deletions
diff --git a/dev-ruby/locale/Manifest b/dev-ruby/locale/Manifest
index 5d20b31ebf1d..6f8c3f8ebfc9 100644
--- a/dev-ruby/locale/Manifest
+++ b/dev-ruby/locale/Manifest
@@ -1,3 +1,5 @@
DIST locale-2.1.2-git.tgz 99433 BLAKE2B b735d913e4a2f1f09131eb9aabc17cee93cd4b28f10458928942a3edd159cd1cde71226d4ad9aa9e340f5df5ba52a298805d1a4e73cb8dbc83d00bcecb7ceb85 SHA512 62a0c60f2102cd2d144126985748f4ab186b8f582c9597f7f4080e782196a39d72b9947b90aaecf5b208ccad0175064ac90e816472fb374d19cb5209da0f7ff4
-EBUILD locale-2.1.2-r1.ebuild 1091 BLAKE2B 38b1e77fc0d20a2cfdd81fdd27d3bee76275c465ebd0109a04e77b75882f45776759796e58462a11f7ab471656139ee9c4fe8da41b2560082ff28697dd932920 SHA512 d1242ba741c5409d373794f1127d1f7ae47d73eab571cd5d7314f5325e1467a149f44167cf30af3846496d7ddc12a84bb71f6ab94b835f3adb9472f760db9d6c
+DIST locale-2.1.3-git.tgz 99648 BLAKE2B e395a442f674c73ed03d0d4d55d875c796add076132964ce2abb457d5d6e2ed8643395f283728735bbbf1ffee8b03549e882e5c66f6a589106a0a36f5b9e4ff1 SHA512 77877f15914dbee5ca83155f8cb84815296b4e2e4205218c9926e0265b40940cbdbe68fb048870ce4f53a6caeeb593813a2e16e8c130a19e44a28cb67c82fe25
+EBUILD locale-2.1.2-r1.ebuild 1091 BLAKE2B ff64e160fb730b96aff1677e34a5012ecbfc021fe9446a8a9790906e23e98099c9e6247168320b1bc033c5b7b3668e65205cd9190f5f7a063021a3f509963e6b SHA512 605d6d36f80f5d769b2770423ef4da58b3f5f721ed2fe70d3d2db5ce7fdf6594e8baeee80467268755d18ff5ed6daf6f35cf2c9f7703b5bd6a8a589879b2bd08
+EBUILD locale-2.1.3.ebuild 1108 BLAKE2B 7876d1e9a92855e5d07d73bccb3478e5e9a5ad9a18df6c26254e360d0c7aed05e0c42359878c8e9eb4c86beb49c54e7f356e3a82b00caa56e0c3f6ccd6453578 SHA512 fed6224ff360150f8266fa35db78dbe6dd0473e4384e46a9a6ed3b534f3c88d33586087d2189bdbc6916cfd0e117aecde75347f5a6ea4c61aee452194558879f
MISC metadata.xml 345 BLAKE2B c2f8101d9e2cd59540e4e95827ac5fa503b0f76bec78ba5a73031b3b966ed1e3153a05aadad5dd563db931881ff3597d1cfb74e113eba53470da11de29eaa809 SHA512 1da3655a6dd1df21971ff6ef41e3fce230f17379bb936ca8a03d1fec427a6904fec717884fd4551d23a493fcec85beb1a9107907c01faadb63b02db8efa0d5af
diff --git a/dev-ruby/locale/locale-2.1.2-r1.ebuild b/dev-ruby/locale/locale-2.1.2-r1.ebuild
index 23bdac39d8b7..7406b9f2bfbb 100644
--- a/dev-ruby/locale/locale-2.1.2-r1.ebuild
+++ b/dev-ruby/locale/locale-2.1.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
diff --git a/dev-ruby/locale/locale-2.1.3.ebuild b/dev-ruby/locale/locale-2.1.3.ebuild
new file mode 100644
index 000000000000..8cf18d9baf26
--- /dev/null
+++ b/dev-ruby/locale/locale-2.1.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc/reference"
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README.rdoc doc/text/news.md"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_GEMSPEC="locale.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pure ruby library which provides basic APIs for localization"
+HOMEPAGE="https://github.com/ruby-gettext/locale"
+LICENSE="|| ( Ruby GPL-2 )"
+SRC_URI="https://github.com/ruby-gettext/locale/archive/${PV}.tar.gz -> ${P}-git.tgz"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-macos"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 dev-ruby/test-unit-rr )"
+
+all_ruby_prepare() {
+ sed -i -e '/notify/ s:^:#:' test/run-test.rb || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc ; then
+ yard || die
+ fi
+}
+
+each_ruby_test() {
+ ${RUBY} test/run-test.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ dodoc -r samples
+}