summaryrefslogtreecommitdiff
path: root/dev-ruby/log4r/log4r-1.1.10-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-ruby/log4r/log4r-1.1.10-r3.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-ruby/log4r/log4r-1.1.10-r3.ebuild')
-rw-r--r--dev-ruby/log4r/log4r-1.1.10-r3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/log4r/log4r-1.1.10-r3.ebuild b/dev-ruby/log4r/log4r-1.1.10-r3.ebuild
new file mode 100644
index 000000000000..1e8c89bcc55e
--- /dev/null
+++ b/dev-ruby/log4r/log4r-1.1.10-r3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+# There are no working tests atm, to be checked on next version bump.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A comprehensive and flexible logging library written in Ruby"
+HOMEPAGE="http://log4r.sourceforge.net/"
+IUSE=""
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ dodoc -r examples
+}