summaryrefslogtreecommitdiff
path: root/dev-ruby/logue/logue-1.0.16.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-27 12:48:57 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-27 12:48:57 +0100
commit70b82ae359a5538711e103b0e8dfb92654296644 (patch)
tree8412b84ff9ce02a22be5251052b00feefe1d5b70 /dev-ruby/logue/logue-1.0.16.ebuild
parent64e107b9b6058580ff0432107eb37cefb0b2a7d8 (diff)
gentoo resync : 27.10.2018
Diffstat (limited to 'dev-ruby/logue/logue-1.0.16.ebuild')
-rw-r--r--dev-ruby/logue/logue-1.0.16.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/logue/logue-1.0.16.ebuild b/dev-ruby/logue/logue-1.0.16.ebuild
new file mode 100644
index 000000000000..83f06819fc19
--- /dev/null
+++ b/dev-ruby/logue/logue-1.0.16.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A module that adds logging/trace functionality"
+HOMEPAGE="https://github.com/jpace/logue"
+
+SRC_URI="https://github.com/jpace/logue/archive/v${PV}.tar.gz -> ${PN}-git-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rainbow:3"
+
+ruby_add_bdepend "test? ( dev-ruby/paramesan )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+
+ # Fix path to match installed gem path
+ sed -i -e 's:logue/lib/logue:/lib/logue:' lib/logue/stack.rb || die
+}