summaryrefslogtreecommitdiff
path: root/dev-ruby/loofah/loofah-2.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:19:44 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:19:44 +0000
commitc5283d322accc6097afec74eab24550829788bab (patch)
treeb99ce668128d82a026eaa31461643f9173f9b77b /dev-ruby/loofah/loofah-2.2.1.ebuild
parent5510d9d7d1c93c2ea71a2bd6f0666168808d5dd6 (diff)
gentoo resync : 23.03.2018
Diffstat (limited to 'dev-ruby/loofah/loofah-2.2.1.ebuild')
-rw-r--r--dev-ruby/loofah/loofah-2.2.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/loofah/loofah-2.2.1.ebuild b/dev-ruby/loofah/loofah-2.2.1.ebuild
new file mode 100644
index 000000000000..6fe034b16a6d
--- /dev/null
+++ b/dev-ruby/loofah/loofah-2.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library for manipulating and transforming HTML/XML documents and fragments."
+HOMEPAGE="https://github.com/flavorjones/loofah"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux"
+IUSE=""
+
+ruby_add_rdepend "=dev-ruby/crass-1.0* >=dev-ruby/crass-1.0.2 >=dev-ruby/nokogiri-1.5.9"
+
+ruby_add_bdepend "test? ( >=dev-ruby/rr-1.1.0 >=dev-ruby/hoe-2.3.0 )"
+
+all_ruby_prepare() {
+ # Avoid unneeded development dependencies
+ sed -i -e '/concourse/I s:^:#:' Rakefile || die
+
+ # Avoid test failing on different whitespace.
+ sed -i -e '/test_fragment_whitewash_on_microsofty_markup/askip "gentoo"' test/integration/test_ad_hoc.rb || die
+
+ # Fix test for new libxml2 results (fixed upstream)
+ #sed -i -e '348i "xhtml": "&lt;&lt;script&gt;alert(\\\"XSS\\\");//&lt;&lt;/script&gt;",' test/assets/testdata_sanitizer_tests1.dat || die
+}