summaryrefslogtreecommitdiff
path: root/dev-ruby/loofah/loofah-2.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-ruby/loofah/loofah-2.4.0.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-ruby/loofah/loofah-2.4.0.ebuild')
-rw-r--r--dev-ruby/loofah/loofah-2.4.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/loofah/loofah-2.4.0.ebuild b/dev-ruby/loofah/loofah-2.4.0.ebuild
new file mode 100644
index 000000000000..7ea90a4b875b
--- /dev/null
+++ b/dev-ruby/loofah/loofah-2.4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library for manipulating and transforming HTML/XML documents and fragments."
+HOMEPAGE="https://github.com/flavorjones/loofah"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux"
+IUSE=""
+
+ruby_add_rdepend "=dev-ruby/crass-1.0* >=dev-ruby/crass-1.0.2 >=dev-ruby/nokogiri-1.5.9"
+
+ruby_add_bdepend "test? ( >=dev-ruby/rr-1.1.0 )"
+
+all_ruby_prepare() {
+ # Avoid unneeded development dependencies
+ sed -i -e '/concourse/I s:^:#:' Rakefile || die
+
+ # Avoid test failing on different whitespace.
+ sed -i -e '/test_fragment_whitewash_on_microsofty_markup/askip "gentoo"' test/integration/test_ad_hoc.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
+}