summaryrefslogtreecommitdiff
path: root/dev-ruby/metaclass/metaclass-0.0.4-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-ruby/metaclass/metaclass-0.0.4-r2.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-ruby/metaclass/metaclass-0.0.4-r2.ebuild')
-rw-r--r--dev-ruby/metaclass/metaclass-0.0.4-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/metaclass/metaclass-0.0.4-r2.ebuild b/dev-ruby/metaclass/metaclass-0.0.4-r2.ebuild
new file mode 100644
index 000000000000..f426efc3f79b
--- /dev/null
+++ b/dev-ruby/metaclass/metaclass-0.0.4-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="metaclass.gemspec"
+
+inherit ruby-fakegem
+SRC_URI="https://github.com/floehopper/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+DESCRIPTION="Adds a __metaclass__ method to all Ruby objects"
+HOMEPAGE="https://github.com/floehopper/metaclass"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile test/test_helper.rb || die
+ sed -i -e 's/git ls-files/find */' -e '/\(test_files\|executables\)/ s:^:#:' ${RUBY_FAKEGEM_GEMSPEC} || die
+}