summaryrefslogtreecommitdiff
path: root/dev-ruby/metasploit-model
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-ruby/metasploit-model
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-ruby/metasploit-model')
-rw-r--r--dev-ruby/metasploit-model/Manifest3
-rw-r--r--dev-ruby/metasploit-model/metadata.xml14
-rw-r--r--dev-ruby/metasploit-model/metasploit-model-2.0.4.ebuild72
3 files changed, 0 insertions, 89 deletions
diff --git a/dev-ruby/metasploit-model/Manifest b/dev-ruby/metasploit-model/Manifest
deleted file mode 100644
index 6e3c1c56de2d..000000000000
--- a/dev-ruby/metasploit-model/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST metasploit-model-2.0.4.gem 81408 BLAKE2B 5a4be9e61649710470618d4334279054cbefc1027a1d4674b6be0c6a4c632219fd2dc3ac5f9f56dc9018712e5cbcbe191d5749ed2ed10cf98f884a06e41ec736 SHA512 70f6d948227bc99f877c3b5631a964087c0ebfdb091f128c72bc5da276bf57a5055aea5cdda4dc66e1fb177606afec9b7b3ee4076211f43928a2defb93294ac5
-EBUILD metasploit-model-2.0.4.ebuild 1876 BLAKE2B 39d6fc56669a08ddbefa7b449ce179d3a981ed5d0faaa489115595ff3cc4763d7b7c3ddc6c5903ef115ba5c113109d2bf37c60695f60ff899c044d19741b0942 SHA512 8551611fa7366cb685ac39048ca04e30cf8d137f99994cfc6562ed50e26f6ca97da01bf8e058fe7210034c24c0e13ece2c422c09db1ccd190451e0e64c6d5fa1
-MISC metadata.xml 541 BLAKE2B 5cbf1dc5abd33de9b63c4b70eceaa58cc2e9b4d4fbf4ebae04ee5ad769c3a419ae7c5e3f5508370f88fc2b3f44e13c5de0ba782322173142211e92a3c713f5b7 SHA512 a61494f72cb863a18cf370ebfdadcda7f4f3ed54e2c9d1e4ab9cf006f26bbefd30b1f293bd3f7df5e766994b044fe27a7b4fb4d78a1c7fdac7e2380aace901cc
diff --git a/dev-ruby/metasploit-model/metadata.xml b/dev-ruby/metasploit-model/metadata.xml
deleted file mode 100644
index 3534a5dd3a91..000000000000
--- a/dev-ruby/metasploit-model/metadata.xml
+++ /dev/null
@@ -1,14 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>zerochaos@gentoo.org</email>
- <name>Rick Farina</name>
- </maintainer>
-<longdescription lang="en">
-Common code, such as validators and mixins, that are shared between ActiveModels in metasploit-framework and ActiveRecords in metasploit_data_models
-</longdescription>
- <upstream>
- <remote-id type="github">rapid7/metasploit-model</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-ruby/metasploit-model/metasploit-model-2.0.4.ebuild b/dev-ruby/metasploit-model/metasploit-model-2.0.4.ebuild
deleted file mode 100644
index 8ef919bb1032..000000000000
--- a/dev-ruby/metasploit-model/metasploit-model-2.0.4.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby24"
-
-inherit ruby-fakegem eapi7-ver
-
-RUBY_FAKEGEM_EXTRAINSTALL="app config script spec"
-
-DESCRIPTION="Common code, such as validators and mixins"
-HOMEPAGE="https://github.com/rapid7/metasploit-model"
-SRC_URI="https://rubygems.org/gems/${P}.gem"
-
-LICENSE="BSD"
-SLOT="$(ver_cut 1-2)"
-KEYWORDS="~amd64 ~arm ~x86"
-#IUSE="development test"
-RESTRICT=test
-IUSE=""
-
-RDEPEND="${RDEPEND} !dev-ruby/metasploit-model:0"
-
-ruby_add_rdepend ">=dev-ruby/railties-4.2.6:4.2
- >=dev-ruby/activesupport-4.2.6:4.2
- >=dev-ruby/activemodel-4.2.6:4.2"
-# development? ( dev-ruby/bundler
-# dev-ruby/rake
-# dev-ruby/i18n
-# dev-ruby/multi_json
-# dev-ruby/builder
-# dev-ruby/erubis
-# dev-ruby/journey
-# dev-ruby/rack
-# dev-ruby/rack-cache
-# dev-ruby/rack-test
-# dev-ruby/hike
-# dev-ruby/tilt
-# dev-ruby/sprockets:*
-# dev-ruby/actionpack:4.0
-# dev-ruby/json
-# dev-ruby/rack-ssl:*
-# dev-ruby/rdoc
-# dev-ruby/thor
-# dev-ruby/redcarpet
-# <dev-ruby/yard-0.8.7.4 )"
-
-ruby_add_bdepend "dev-ruby/bundler"
-
-all_ruby_prepare() {
- [ -f Gemfile.lock ] && rm Gemfile.lock
- #For now, we don't support development or testing at all
- #if ! use development; then
- sed -i -e "/^group :development do/,/^end$/d" Gemfile || die
- sed -i -e "/s.add_development_dependency/d" "${PN}".gemspec || die
- sed -i -e "/spec.add_development_dependency/d" "${PN}".gemspec || die
- #fi
- #if ! use test; then
- sed -i -e "/^group :test do/,/^end$/d" Gemfile || die
- #fi
- #if ! use test && ! use development; then
- sed -i -e "/^group :development, :test do/,/^end$/d" Gemfile || die
- #fi
-}
-
-each_ruby_prepare() {
- if [ -f Gemfile ]
- then
- BUNDLE_GEMFILE=Gemfile ${RUBY} -S bundle install --local || die
- BUNDLE_GEMFILE=Gemfile ${RUBY} -S bundle check || die
- fi
-}