summaryrefslogtreecommitdiff
path: root/dev-ruby/mixlib-shellout
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-20 00:10:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-20 00:10:57 +0100
commitd6ca4e4f90cb75c323b5988eefa96a04c0d36908 (patch)
tree8197fc88451976470c871e991b75a9d40c240270 /dev-ruby/mixlib-shellout
parente8df704cf9b5e9e517317b8912377c0a8ca0d11e (diff)
gentoo auto-resync : 20:06:2024 - 00:10:56
Diffstat (limited to 'dev-ruby/mixlib-shellout')
-rw-r--r--dev-ruby/mixlib-shellout/Manifest2
-rw-r--r--dev-ruby/mixlib-shellout/mixlib-shellout-3.2.8.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/mixlib-shellout/Manifest b/dev-ruby/mixlib-shellout/Manifest
index 7b1cd7df0060..54b61ce7aefe 100644
--- a/dev-ruby/mixlib-shellout/Manifest
+++ b/dev-ruby/mixlib-shellout/Manifest
@@ -1,5 +1,7 @@
DIST mixlib-shellout-3.0.9.tar.gz 42476 BLAKE2B 4fab1d0f7d7ee5190f65d312304c7137d940b5cc19bb205d4de1d14eb5bc5829671560785b7f3179220246433b15b9022f8a1d16fb7491e180940c9dc6da5280 SHA512 7234c188e25cc6da3c4859eb12e4f86ce0d6538d17e4c90b1b5105fe677fcd13d884d7045be9767473c3ac63ffcfac7af25dc8efcec184928ba32852a5a760cc
DIST mixlib-shellout-3.2.7.tar.gz 46666 BLAKE2B 0ee97eef27618d326487a3884115d0954147297a75001404c8df0717f71c6acde5ec9ebc9320d12493f1ce4e65b3d74ba1143ba7e4a631629de0d65e3b50bcb7 SHA512 de1d07e7a3f26ec934f57a37a82995b5522a5c196263b7ff1917c1a77cce3104d67a8dccab2aa907c3db854520ce6b5f78ef33fca8d4bffd0ba0cc659da1c16f
+DIST mixlib-shellout-3.2.8.tar.gz 46644 BLAKE2B 329e5e92fda0677e417cf938988d610b6da324bb1b9e4044dd9e4feac97aff8b1b54d89ad91e29e6e0c196d6429b43e5b52a0da57ae8c0ce59e9242b5f08bd48 SHA512 8b801c63ff458c50807802bf0e5c055f978ebe8104c310e12b00508b00eb57ccdbee0672ebf0bdb601f82064a0279f3f07291cc24d59b3eacb7aa51fb39ecc99
EBUILD mixlib-shellout-3.0.9-r1.ebuild 902 BLAKE2B 324d2f38b73857cb795c1bb539da6cb0f81f33cb1d2d1c6df5ee9f9426031f3a25296a1a59072a8a2206deafb1d4886016202d39051eac638505aa89f7e4638b SHA512 7ae859ae3b31a1b900300f1c0aa183bb74a834e2ec7387509b1aa67a4d51ccc0c101950dc837b71a9bd8a760df3966d3f70635f409a3b93614ae5df1b91da275
EBUILD mixlib-shellout-3.2.7.ebuild 942 BLAKE2B e396f331f11ccffa4b79bebcc4e2568c5cb498488264bc62da6801a0ade2a05d9966833f76a241180bcd54a797cd74d5cde784b5f7bc66cd5042afcaf6d489a9 SHA512 338537d55d4845f2532e1e1672b074d231811b14716e3087b58d887a063cc40f1ddc2d627e856b86cffa9b41dc878dfdd3d4b915937a91089188a3dfcb379876
+EBUILD mixlib-shellout-3.2.8.ebuild 934 BLAKE2B 5450bcda82db92b6ca6ea29d1794bbfb9706dab8933258b9c2a6288918e151fcdabb149fc65f756a16165f717db2ea11915114c4357e6d617c59c3a976df389c SHA512 4be710db12454127653e3de45354e2091b5e2e20c1ead743ed401d8e152195dac0daf66a920e67d63334fb67596967de7f787d0b6075f30161fad6530eb2e7ca
MISC metadata.xml 347 BLAKE2B ab588c71a4d6866a8524826b4241ff8ecc36719eadda2690954e9039c5395ce54a5c6f3a48c69fff6adc4af39ad30cecbb18d4d3e91c29eba461ed02406cb33f SHA512 836e04df48dcb26a162cfc682eec084d1b5ad570afec8cf092581f0017717bdf141460b2bfc14e4f06d2b3ced2818474fc5044a460117d327af551f3a3d635bb
diff --git a/dev-ruby/mixlib-shellout/mixlib-shellout-3.2.8.ebuild b/dev-ruby/mixlib-shellout/mixlib-shellout-3.2.8.ebuild
new file mode 100644
index 000000000000..86cd9e250fc0
--- /dev/null
+++ b/dev-ruby/mixlib-shellout/mixlib-shellout-3.2.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRA_DOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="mixlib-shellout.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Run external commands on Unix or Windows"
+HOMEPAGE="https://github.com/chef/mixlib-shellout"
+SRC_URI="https://github.com/chef/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+ruby_add_rdepend "dev-ruby/chef-utils"
+
+each_ruby_prepare() {
+ # Make sure we actually use the right interpreter for testing
+ sed -i -e "/ruby_eval/ s:ruby :${RUBY} :" spec/mixlib/shellout_spec.rb || die
+
+ # Avoid spec that requires an interactive terminal
+ sed -e '/with subprocess writing lots of data to both stdout and stderr/,/^ end/ s:^:#:' \
+ -i spec/mixlib/shellout_spec.rb || die
+}