summaryrefslogtreecommitdiff
path: root/dev-ruby/multipart-post
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/multipart-post
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/multipart-post')
-rw-r--r--dev-ruby/multipart-post/Manifest3
-rw-r--r--dev-ruby/multipart-post/metadata.xml11
-rw-r--r--dev-ruby/multipart-post/multipart-post-2.0.0-r1.ebuild25
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/multipart-post/Manifest b/dev-ruby/multipart-post/Manifest
new file mode 100644
index 000000000000..0d7ab5d566e9
--- /dev/null
+++ b/dev-ruby/multipart-post/Manifest
@@ -0,0 +1,3 @@
+DIST multipart-post-2.0.0.gem 11264 BLAKE2B a842e810dd5ccc4a03509003ec1fe87ff7faed80501e776b7d10bf01d64405a4ff01812e9c6ca600207d268f0abe37dd164b54307cdb446719602bc81787b885 SHA512 4f48c815d82c139986f419cdb12efd2f3792f2ef0b2277b75533c8ddad17cc6a8c187deddadc82d29c9f7f8337fcc9ad23c40eb72053ac933911ec1457b01c18
+EBUILD multipart-post-2.0.0-r1.ebuild 575 BLAKE2B 7a9a1706024dc183c47b3d573eee8423f33ab6dd6dd3d0bb4d8a688460c87d2d08f62d1bdf1e955c6d2c9c09dba22a8768e021c78047b417aab493500321128c SHA512 5c5efd26310aa63b68467e107862018d8cb368972960bab0a8255f043d3f3faa985dcd79f399fa1a059169c0af9f0fae24689bec17a345a04d656b59eb540d31
+MISC metadata.xml 351 BLAKE2B 1b91932f0fac0566cc3a283f50d5162f09b9ae0f06ee2419f5be35cb6fb9b6b7234c4c8974c89d38eae80ad2a642b1ba5a927506442ab2906a4d43832a2207b5 SHA512 d25464b95046a3df4a9989cdc012fa2220f9d0008f48bc16bc54e87fe6cb99ce0e4548e042ed96675d917a68a2c2e7fcbc3054c66fe5879eb6761cacddb7c51c
diff --git a/dev-ruby/multipart-post/metadata.xml b/dev-ruby/multipart-post/metadata.xml
new file mode 100644
index 000000000000..5b3bfe943553
--- /dev/null
+++ b/dev-ruby/multipart-post/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">nicksieger/multipart-post</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/multipart-post/multipart-post-2.0.0-r1.ebuild b/dev-ruby/multipart-post/multipart-post-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..e2c7ae596b20
--- /dev/null
+++ b/dev-ruby/multipart-post/multipart-post-2.0.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.md"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Adds a streamy multipart form post capability to Net::HTTP"
+HOMEPAGE="https://github.com/nicksieger/multipart-post"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:. -e "Dir['test/test_*.rb'].each{|f| require f}" || die
+}