summaryrefslogtreecommitdiff
path: root/dev-ruby/net-http-pipeline
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/net-http-pipeline
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/net-http-pipeline')
-rw-r--r--dev-ruby/net-http-pipeline/Manifest5
-rw-r--r--dev-ruby/net-http-pipeline/files/net-http-pipeline-accept-encoding.patch18
-rw-r--r--dev-ruby/net-http-pipeline/metadata.xml11
-rw-r--r--dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild23
4 files changed, 57 insertions, 0 deletions
diff --git a/dev-ruby/net-http-pipeline/Manifest b/dev-ruby/net-http-pipeline/Manifest
new file mode 100644
index 000000000000..b049e2112f41
--- /dev/null
+++ b/dev-ruby/net-http-pipeline/Manifest
@@ -0,0 +1,5 @@
+AUX net-http-pipeline-accept-encoding.patch 654 SHA256 48c6b7de42be91cd05cf8a22098f06a0b8db7a9aa4ea8499f3e607181f5391e5 SHA512 43c6382f01538faaedc38047d6099d26c6d91805c45eddd043fba0e98b4331fa42a2826ea8a3216ddd5ab047b37e8a7ce1ba4c52b9ed5c0c645a5483d2cd1931 WHIRLPOOL 65dd7a781ba1e0ccfacf3dfe3431ff4bb03892b7a756f221b0ca94b28a120b624876d0da50420559bdf982cf69a15dba84131bc0c15b925338cd2bbd1b22fff7
+DIST net-http-pipeline-1.0.1.gem 12800 SHA256 6923ce2f28bfde589a9f385e999395eead48ccfe4376d4a85d9a77e8c7f0b22f SHA512 1377c20038176f6c246a7d4adbce2c6972970d730902f9faefc31b2f6446f4237603f45f0f59de70eb9545e3c1e150fe6e63cf350551203166611bef7845f4e2 WHIRLPOOL 691e995dbe5f3fc4605923511f0bea634f5a3558acb629b3694ffe5757392f8943c5c070b814f2a442c1cc3fefa89fd4f3da08773aae340e0b2b7bcfd2769be8
+EBUILD net-http-pipeline-1.0.1.ebuild 492 SHA256 baa8d96f82bcce32e6303364d55b94aa05fc2d31208e1bad7150de01b2e92cd2 SHA512 514f55f720aa176f67b328ac951d9e8369498ecd02b10a0a8bd3d32ce0165176c6365f2992a428f5764ec806b5e0861e253f547f09ad4089cbc3723049e7770e WHIRLPOOL 7bca2773ea17a6fa2d1e88e885c8f2751b007fb66dd465a2b4080f64993665b9223864f6bb2334444857ffc0e4c09e8afdea226a62a7ea604a5f71233bc0429d
+MISC ChangeLog 544 SHA256 049728a415b13d6b4db0de82074a949e7939f0a544fa6518cdaa18cb12e4e94f SHA512 f60ff7076134e9f102495a0444f1c8865a003531064153dc576e4464ec3014aea459cd0f15a92b89356d227f7625e797f335e2c0b9ea49d871759cffa324674f WHIRLPOOL a4241a4b1b62efc5622d3821bf48990da1b7cf5cfab9a6737277fa241756284ee1549a5a9231482fed94eb253225bb6832d81932ec36b7a2fc0535c86df85004
+MISC metadata.xml 347 SHA256 80e79512abd88bc875333a7a3bc03d5dc7e5afc8a11d0108394f3df6280950c7 SHA512 6dcbad5588fb9362b1be0ce300b0032ac5f83fc5216257a4af079e8b327d25db1494809a9596b8684bee95654dcab8037f9218db0581a3ec2ade8d3563bd7121 WHIRLPOOL 2c664de8dbeae37aa956c946a85b4fc03bdef9c62bbdaa8c8f8ec57a6c3e1d99fb7e99131ac2df4987b66ebe6ed633cbabf033602b0701218d1792ccc385a9b9
diff --git a/dev-ruby/net-http-pipeline/files/net-http-pipeline-accept-encoding.patch b/dev-ruby/net-http-pipeline/files/net-http-pipeline-accept-encoding.patch
new file mode 100644
index 000000000000..3adfdf28afdc
--- /dev/null
+++ b/dev-ruby/net-http-pipeline/files/net-http-pipeline-accept-encoding.patch
@@ -0,0 +1,18 @@
+--- test/test_net_http_pipeline.rb.old 2016-11-17 07:58:57.284997283 +0100
++++ test/test_net_http_pipeline.rb 2016-11-17 07:58:50.345168508 +0100
+@@ -96,6 +96,7 @@
+ def http_get
+ get = []
+ get << 'GET / HTTP/1.1'
++ get << 'Accept-Encoding: gzip;q=1.0,deflate;q=0.6,identity;q=0.3'
+ get << 'Accept: */*'
+ get << 'User-Agent: Ruby' if RUBY_VERSION > '1.9'
+ get.push nil, nil
+@@ -106,6 +107,7 @@
+ def http_post
+ get = []
+ get << 'POST / HTTP/1.1'
++ get << 'Accept-Encoding: gzip;q=1.0,deflate;q=0.6,identity;q=0.3'
+ get << 'Accept: */*'
+ get << 'User-Agent: Ruby' if RUBY_VERSION > '1.9'
+ get.push nil, nil
diff --git a/dev-ruby/net-http-pipeline/metadata.xml b/dev-ruby/net-http-pipeline/metadata.xml
new file mode 100644
index 000000000000..59da3fd2d7d7
--- /dev/null
+++ b/dev-ruby/net-http-pipeline/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">drbrain/net-http-pipeline</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild b/dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild
new file mode 100644
index 000000000000..e1b3a1c05690
--- /dev/null
+++ b/dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An HTTP/1.1 pipelining implementation atop Net::HTTP"
+HOMEPAGE="http://docs.seattlerb.org/net-http-pipeline/"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+RUBY_PATCHES=( ${PN}-accept-encoding.patch )
+
+ruby_add_bdepend "
+ dev-ruby/hoe
+ test? ( dev-ruby/minitest )
+"