summaryrefslogtreecommitdiff
path: root/dev-ruby/oauth-tty
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-16 12:27:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-16 12:27:58 +0100
commitb6fa31c964a602f8461a77d5b83355e8750c12eb (patch)
tree323fa7af31640b3ea8bb57fa7a927713f3d64769 /dev-ruby/oauth-tty
parent868fd5dc8aab84930cfaa5252b8be06b35552765 (diff)
gentoo auto-resync : 16:07:2024 - 12:27:58
Diffstat (limited to 'dev-ruby/oauth-tty')
-rw-r--r--dev-ruby/oauth-tty/Manifest3
-rw-r--r--dev-ruby/oauth-tty/metadata.xml11
-rw-r--r--dev-ruby/oauth-tty/oauth-tty-1.0.5.ebuild52
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-ruby/oauth-tty/Manifest b/dev-ruby/oauth-tty/Manifest
new file mode 100644
index 000000000000..7967922a6f2d
--- /dev/null
+++ b/dev-ruby/oauth-tty/Manifest
@@ -0,0 +1,3 @@
+DIST oauth2-1.0.5.tar.bz2 27649 BLAKE2B cb20b0073838ad887b2b7311e929507d152746c33adeef602f475fca94aa49df4283597ab678f2fa16d17467220edab6601e7ff4bae07d5c81b55cf8515ca5eb SHA512 3dbb5d1394bf5791b16e88bb4e8ead7456ea935005947e0e6b5e4864277b17c75acea389d5c7e5eef1eff684475962619777728049f8f0686abe434f2fffacf8
+EBUILD oauth-tty-1.0.5.ebuild 1201 BLAKE2B fe99b37988919b623d88864dbf21f997d693412d3db0e883e2f56597d73b2d9c0d9b105ae7029ac25ca581728ccea81d8437900aeaf88f08e2e81691b4309d30 SHA512 ba0a9955e3fec858deb1bed48940b8eb08043e8bf9b0ce693aa10f24245cb14f9192dee89b47e4a687b073f41fd61d1f594b98318550c515f3e6ae81de1f2517
+MISC metadata.xml 345 BLAKE2B c2c1af79cb4f0d3bc5f3b0d1c890fc8f8610a4ec08ec19e0ab56dc1ea2ec9ee02e9937f3b0f9553c6dd7fc30eb6a7e69330b4ae29bf95c42557deaee3beea093 SHA512 cab9ca61f0d75dc8a99cb31e59722610b8f9de1f54fe6dc341bc2a56a4abd97ccdb79a3416b13d8d1e1d8825f34b4b4da36584d5718bea2dd4e357f7b7dba07e
diff --git a/dev-ruby/oauth-tty/metadata.xml b/dev-ruby/oauth-tty/metadata.xml
new file mode 100644
index 000000000000..5082bc5c9e92
--- /dev/null
+++ b/dev-ruby/oauth-tty/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="gitlab">oauth-xx/oauth-tty</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/oauth-tty/oauth-tty-1.0.5.ebuild b/dev-ruby/oauth-tty/oauth-tty-1.0.5.ebuild
new file mode 100644
index 000000000000..cb1572ab46d0
--- /dev/null
+++ b/dev-ruby/oauth-tty/oauth-tty-1.0.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_BINDIR="exe"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="oauth-tty.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="OAuth 1.0 TTY Command Line Interface"
+HOMEPAGE="https://gitlab.com/oauth-xx/oauth-tty"
+SRC_URI="https://gitlab.com/oauth-xx/oauth-tty/-/archive/v${PV}/oauth2-${PV}.tar.bz2"
+RUBY_S="${PN}-v${PV}-*"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~ppc ~riscv ~x86"
+IUSE="test"
+
+ruby_add_rdepend "
+ >=dev-ruby/version_gem-1.1.1:1
+ !<dev-ruby/oauth-0.6.2-r2:0
+"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/minitest-5.15
+ dev-ruby/mocha
+ >=dev-ruby/oauth-1.1.0
+ dev-ruby/rack-test
+ dev-ruby/webmock
+)"
+
+all_ruby_prepare() {
+ # Avoid unneeded coverage tools
+ sed -e 's/if RUN_COVERAGE/if false/' -i test/test_helper.rb || die
+
+ # Fix deprecated minitest names
+ sed -e 's/MiniTest/Minitest/' -i test/*_test.rb || die
+
+ # # Avoid test tripped up by kwargs confusion
+ sed -e '/test_authorize/askip "kwargs confusion"' \
+ -i test/cli_test.rb || die
+
+ sed -e 's:_relative ": "./:' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}