summaryrefslogtreecommitdiff
path: root/dev-ruby/oauth/oauth-0.5.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-26 14:59:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-26 14:59:08 +0100
commit1503b28e7a30c164cab750c27268f704b8a5cec6 (patch)
treed06a47a18b0fb792e95f88ea6e18af234eb0b9d5 /dev-ruby/oauth/oauth-0.5.10.ebuild
parent34ce8f465101950c92cb66c657d3244b5a8397db (diff)
gentoo auto-resync : 26:07:2022 - 14:59:07
Diffstat (limited to 'dev-ruby/oauth/oauth-0.5.10.ebuild')
-rw-r--r--dev-ruby/oauth/oauth-0.5.10.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-ruby/oauth/oauth-0.5.10.ebuild b/dev-ruby/oauth/oauth-0.5.10.ebuild
index 6aacd85e42e9..d2a781ddc4e8 100644
--- a/dev-ruby/oauth/oauth-0.5.10.ebuild
+++ b/dev-ruby/oauth/oauth-0.5.10.ebuild
@@ -32,8 +32,14 @@ ruby_add_bdepend "test? (
all_ruby_prepare() {
# Require a compatible version of mocha
- sed -i -e '1igem "mocha", "~> 1.0"; gem "railties", "~>6.1.0" ; gem "actionpack", "~>6.1.0"' \
- -e '2i gem "test-unit"; require "test/unit"' \
+ sed -i -e '1igem "mocha", "~> 1.0"; gem "railties", "~>6.1.0" ; gem "actionpack", "~>6.1.0"; require "action_dispatch"' \
-e '/mocha/ s/mini_test/minitest/' \
-e '/\(byebug\|minitest_helpers\|simplecov\)/I s:^:#:' test/test_helper.rb || die
+
+ # Avoid test tripped up by kwargs confusion
+ sed -i -e '/test_authorize/askip "kwargs confusion"' test/units/test_cli.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'Dir["test/**/*test*.rb"].each {|f| require f}' || die
}