summaryrefslogtreecommitdiff
path: root/dev-ruby/oauth2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-10 11:43:22 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-10 11:43:22 +0100
commit1d412f04b6e137f20cbe616b3203d2cbc8dfd5ad (patch)
tree37690cdf0c1532996a40987cf1d65e80d21886c4 /dev-ruby/oauth2
parent100b0ae24e9b0d0fb3071efea2078a3bdabe4e38 (diff)
gentoo auto-resync : 10:05:2023 - 11:43:22
Diffstat (limited to 'dev-ruby/oauth2')
-rw-r--r--dev-ruby/oauth2/Manifest4
-rw-r--r--dev-ruby/oauth2/metadata.xml2
-rw-r--r--dev-ruby/oauth2/oauth2-1.4.11.ebuild59
3 files changed, 63 insertions, 2 deletions
diff --git a/dev-ruby/oauth2/Manifest b/dev-ruby/oauth2/Manifest
index 5f2f13153cb1..df128774c3ae 100644
--- a/dev-ruby/oauth2/Manifest
+++ b/dev-ruby/oauth2/Manifest
@@ -1,3 +1,5 @@
DIST oauth2-1.4.10.tar.gz 65553 BLAKE2B 4b147a97536ae04b81ca5bc41117bc31c577aae9b7dc1f4f34830d3cd7b7013098e90ae83997c4917ca25e858b8738398eb708bfee954882359ed14b8e810172 SHA512 cee9e1f890f66252451cc22ab7135dda60c73bb200f2f1659a450b09dccc0a219982625ec45866dc9153669a4d35fb543fb6de497bfa83522b99c66e9c8b9d9b
+DIST oauth2-1.4.11.tar.bz2 65622 BLAKE2B 9a09e69eb2389289d5b048388dd52dd6edcf289c4d7262ead05cca7dd27b261b6f432e023ac3c34aa77d6fa33bca5d870726b96cf5bf85eeec3561e9b53f9501 SHA512 12a9133cd5813eed00c2a22995630a7fdb611b0d76b06eeb8c938fd826831ea37556822246f21a739ba427c74135e6c2046edc1fb008725c55f3b1000ab5a945
EBUILD oauth2-1.4.10.ebuild 1499 BLAKE2B 8dcb6bfb83aa65af9fb62c43e81558ce739d06a1893150c355e030b8b2bbb1abc9160dd2d3ca8f2e2ac3dfbd1ba0c27a74da4cbd078bc45794515d27ab32fc05 SHA512 fcfed86236da49c2fa5df5d0920441dde1d15b1fd7af54e2933a7c61c4a92491fa2642807dd5c663ac0f44b14e7df40ceca4586695ef3cd1094b5577234bf051
-MISC metadata.xml 342 BLAKE2B 14d2af934a4327d3d6c1c5236c0b5a0436c91cc3988d6957188171153c60a0f40b6dec75cb5acac49aa60518f89cc5bdb00e92021ca99249903f937df51f1b23 SHA512 cc8c7abab8d16e0ef97ec14f58bfc5941e161b2676950aaa45912812d53e523a54570407bcb2e9cd2527a0c6acca8f348422efdde66402c162e8a04dcfaabb8f
+EBUILD oauth2-1.4.11.ebuild 1581 BLAKE2B 6523f01566c69882db4cd606d1fb99c0aafbb008726ea8d34c260b0d35e77d01984259517f3d3de5522f63f472fdebf7b33b87138745f963e228a706716fd3c7 SHA512 6dde5179a9427377d037cc7aeb374cdfd010af0b7eac77cd5b36699058d5bf52426a4322d2c068fa72a28944907ddd594f47e12c898f2fac29ec07e2fdee5075
+MISC metadata.xml 342 BLAKE2B 0080dc708a99cdd0861b14ecd773251e5719b249171dfaca247f241b1cab03c83bb2593b31a26dcbd02c5767bb27d385600b0dfdd4c8771c9d8b78fd55a26682 SHA512 a8b1d3f086a524b4b4b48465cb26707cacc4a7862ba46639946b67e822df34fdd5bb0fbde7daa3712dfcf9ec08946125710abb79d0e97dd6a819201d3b88df3d
diff --git a/dev-ruby/oauth2/metadata.xml b/dev-ruby/oauth2/metadata.xml
index 59f7d3b5910c..09a70a6befc5 100644
--- a/dev-ruby/oauth2/metadata.xml
+++ b/dev-ruby/oauth2/metadata.xml
@@ -6,6 +6,6 @@
<name>Gentoo Ruby Project</name>
</maintainer>
<upstream>
- <remote-id type="github">intridea/oauth2</remote-id>
+ <remote-id type="gitlab">oauth-xx/oauth2</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-ruby/oauth2/oauth2-1.4.11.ebuild b/dev-ruby/oauth2/oauth2-1.4.11.ebuild
new file mode 100644
index 000000000000..286c19cd9e96
--- /dev/null
+++ b/dev-ruby/oauth2/oauth2-1.4.11.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="oauth2.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Wrapper for the OAuth 2.0 protocol with a similar style to the OAuth gem"
+HOMEPAGE="https://gitlab.com/oauth-xx/oauth2"
+SRC_URI="https://gitlab.com/oauth-xx/oauth2/-/archive/v${PV}/oauth2-${PV}.tar.bz2"
+RUBY_S="oauth2-v${PV}-d41fb6e8feef3b0b0382dedc0ede82f5ca7854cd"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend "
+ || ( dev-ruby/faraday:2 dev-ruby/faraday:1 )
+ dev-ruby/jwt:2
+ >=dev-ruby/multi_json-1.3 =dev-ruby/multi_json-1*
+ >=dev-ruby/multi_xml-0.5:0
+ >=dev-ruby/rack-1.2:* <dev-ruby/rack-4:*"
+ruby_add_bdepend "test? (
+ >=dev-ruby/addressable-2.3
+ >=dev-ruby/rexml-3.2:3
+ dev-ruby/rspec:3
+ dev-ruby/rspec-pending_for
+ dev-ruby/rspec-stubbed_env
+)"
+
+all_ruby_prepare() {
+ sed \
+ -e '/silent/I s:^:#:' \
+ -e '/require.*oauth2/arequire "oauth2/version"' \
+ -i spec/helper.rb || die
+
+ sed -i -e '/yardstick/,/^end/ s:^:#:' \
+ -e '/bundler/I s:^:#:' Rakefile || die
+
+ # Avoid spec that is too fragile in relation to ENV
+ sed -i -e '/outputs to $stdout when OAUTH_DEBUG=true/a skip "fragile ENV stubbing"' spec/oauth2/client_spec.rb || die
+
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ CI=true ${RUBY} -S rspec-3 --format progress spec || die
+}