summaryrefslogtreecommitdiff
path: root/dev-ruby/oauth2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /dev-ruby/oauth2
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'dev-ruby/oauth2')
-rw-r--r--dev-ruby/oauth2/Manifest2
-rw-r--r--dev-ruby/oauth2/oauth2-1.4.7.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-ruby/oauth2/Manifest b/dev-ruby/oauth2/Manifest
index 08efb5e6f5f7..cdd52ea257dc 100644
--- a/dev-ruby/oauth2/Manifest
+++ b/dev-ruby/oauth2/Manifest
@@ -1,3 +1,5 @@
DIST oauth2-1.4.4.tar.gz 28477 BLAKE2B 925008fcf4dd48da3b17c539713bf0f05f649d431ab1676293de625bef4165f31153271d48bbb0c6265c67d7bb6a3cbc7217ce155ba331b22a00d572a855a8ef SHA512 5398a25664e53d1942b0ecbe5d74ca9cc8f04a928c96073f40cfff207c4bf220634185320954a0d1f36944547fb48264855c9523318fbb79dd4a3779a7a46e79
+DIST oauth2-1.4.7.tar.gz 32341 BLAKE2B f3db3ff7ebcf7bc0958a564fdb0812c1bfb613148c5a16655f276fda4d6dac7769196305d854ee0fc3f8b4b53a93b4ae504b348029e1b363bcb704293887347a SHA512 4a43b3f75e827e9a12a74a6fe13a29b141c0d5bcb6a0d5c86dc8d8726f650a9fd5250ecc2c31cee5e985f0cb50e02f828d27fd07577bcac4dfc8ff4e009bd710
EBUILD oauth2-1.4.4.ebuild 1436 BLAKE2B 44a59fa034c7072572c3cee2c7ea8ec607f65dc9aca250b056c21d69b2ecd843367d9035086d098192d8f2757e1669025c4514e945c77e66c2591283cce2c2d9 SHA512 e71b59e6f05600f133258aa212f4dcd1a55e9099f156dddddc1d39406e34c512d137f5da00c10f4ba676bf6ced4951f08cd2c7239aee6239e5a72abbc8089535
+EBUILD oauth2-1.4.7.ebuild 1485 BLAKE2B 80e0f69730cccb197b36fefe63a134fd8b8ebc0410ba90a90caf2fead878b453387873feaae4417274b8c42111ff82aa22c495235cfacfac7351ac40f5c65ca6 SHA512 1f0cd51dbc5ecff49624226a52b4c5db605bccfc2a357c70711cc88d7d4e9273df33706b6e410bb979e83fedb1f504c99b96a2a2e0a14bd86ded2943d7c329a5
MISC metadata.xml 341 BLAKE2B e2896d1d266992c01ed373b489cf71b9c4a7a5f57a2af37899ff63793dad41b9213eee0fd94f269735f630815819f0a08e51e8739b89a7e251b60c2f6894e26c SHA512 33c5be74161557ae3e5888730256536cd02baac6c26913add84d8ce90854c4a3bb57c31fec1287bf560268c681ea3acf2119f2fea3162dd07e3962ee34d74f9e
diff --git a/dev-ruby/oauth2/oauth2-1.4.7.ebuild b/dev-ruby/oauth2/oauth2-1.4.7.ebuild
new file mode 100644
index 000000000000..08c977da7165
--- /dev/null
+++ b/dev-ruby/oauth2/oauth2-1.4.7.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="oauth2.gemspec"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Wrapper for the OAuth 2.0 protocol with a similar style to the OAuth gem"
+HOMEPAGE="https://github.com/intridea/oauth2"
+SRC_URI="https://github.com/intridea/oauth2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/faraday-0.8 <dev-ruby/faraday-2.0
+ dev-ruby/jwt:2
+ >=dev-ruby/multi_json-1.3 =dev-ruby/multi_json-1*
+ >=dev-ruby/multi_xml-0.5:0
+ >=dev-ruby/rack-1.2:* <dev-ruby/rack-3:*"
+ruby_add_bdepend "test? (
+ >=dev-ruby/addressable-2.3
+ dev-ruby/rspec:3
+ dev-ruby/rspec-stubbed_env
+)"
+
+all_ruby_prepare() {
+ sed -e '/simplecov/,/^ end/ s:^:#:' \
+ -e '/silent/I s:^:#:' \
+ -e '1irequire "uri"' \
+ -e '/require.*oauth2/arequire "oauth2/version"' \
+ -i spec/helper.rb || die
+
+ sed -i -e '/yardstick/,/^end/ s:^:#:' \
+ -e '/bundler/I s:^:#:' Rakefile || die
+
+ # Avoid spec that is too fragile in relation to ENV
+ sed -i -e '/outputs to $stdout when OAUTH_DEBUG=true/a skip "fragile ENV stubbing"' spec/oauth2/client_spec.rb || die
+
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ CI=true ${RUBY} -S rspec-3 spec || die
+}