summaryrefslogtreecommitdiff
path: root/dev-ruby/oauth2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-07 11:29:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-07 11:29:55 +0100
commita17b25a10359070f9527893d861369d378021aa9 (patch)
tree02188942c1da9eb507b509fbd36c9b7a5aff86c8 /dev-ruby/oauth2
parentefbb52742172c497c5245486906aade0fb6220e8 (diff)
gentoo auto-resync : 07:04:2023 - 11:29:55
Diffstat (limited to 'dev-ruby/oauth2')
-rw-r--r--dev-ruby/oauth2/Manifest2
-rw-r--r--dev-ruby/oauth2/oauth2-1.4.7.ebuild55
2 files changed, 0 insertions, 57 deletions
diff --git a/dev-ruby/oauth2/Manifest b/dev-ruby/oauth2/Manifest
index 130a187b86ef..5f2f13153cb1 100644
--- a/dev-ruby/oauth2/Manifest
+++ b/dev-ruby/oauth2/Manifest
@@ -1,5 +1,3 @@
DIST oauth2-1.4.10.tar.gz 65553 BLAKE2B 4b147a97536ae04b81ca5bc41117bc31c577aae9b7dc1f4f34830d3cd7b7013098e90ae83997c4917ca25e858b8738398eb708bfee954882359ed14b8e810172 SHA512 cee9e1f890f66252451cc22ab7135dda60c73bb200f2f1659a450b09dccc0a219982625ec45866dc9153669a4d35fb543fb6de497bfa83522b99c66e9c8b9d9b
-DIST oauth2-1.4.7.tar.gz 32341 BLAKE2B f3db3ff7ebcf7bc0958a564fdb0812c1bfb613148c5a16655f276fda4d6dac7769196305d854ee0fc3f8b4b53a93b4ae504b348029e1b363bcb704293887347a SHA512 4a43b3f75e827e9a12a74a6fe13a29b141c0d5bcb6a0d5c86dc8d8726f650a9fd5250ecc2c31cee5e985f0cb50e02f828d27fd07577bcac4dfc8ff4e009bd710
EBUILD oauth2-1.4.10.ebuild 1499 BLAKE2B 8dcb6bfb83aa65af9fb62c43e81558ce739d06a1893150c355e030b8b2bbb1abc9160dd2d3ca8f2e2ac3dfbd1ba0c27a74da4cbd078bc45794515d27ab32fc05 SHA512 fcfed86236da49c2fa5df5d0920441dde1d15b1fd7af54e2933a7c61c4a92491fa2642807dd5c663ac0f44b14e7df40ceca4586695ef3cd1094b5577234bf051
-EBUILD oauth2-1.4.7.ebuild 1478 BLAKE2B 5dd9591470cc825729a00b24de2332d27d4baaab0a78525187ac89d5895a80b7908e3b0fc485cb16d7f7673f8c4613780b5c72eddef1de1d93e99759cf717a37 SHA512 b22a376f34809b148fbfe899adcb65f8ee1544f8abd227eff9937fd05ba824a4f66ea1199515f86976bf4e6ba591e0571b4aed972e4b29c2ae961debc3787edd
MISC metadata.xml 342 BLAKE2B 14d2af934a4327d3d6c1c5236c0b5a0436c91cc3988d6957188171153c60a0f40b6dec75cb5acac49aa60518f89cc5bdb00e92021ca99249903f937df51f1b23 SHA512 cc8c7abab8d16e0ef97ec14f58bfc5941e161b2676950aaa45912812d53e523a54570407bcb2e9cd2527a0c6acca8f348422efdde66402c162e8a04dcfaabb8f
diff --git a/dev-ruby/oauth2/oauth2-1.4.7.ebuild b/dev-ruby/oauth2/oauth2-1.4.7.ebuild
deleted file mode 100644
index 255cac1628cc..000000000000
--- a/dev-ruby/oauth2/oauth2-1.4.7.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_TASK_TEST="none"
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-RUBY_FAKEGEM_GEMSPEC="oauth2.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Wrapper for the OAuth 2.0 protocol with a similar style to the OAuth gem"
-HOMEPAGE="https://github.com/intridea/oauth2"
-SRC_URI="https://github.com/intridea/oauth2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/faraday-0.8 <dev-ruby/faraday-2.0
- dev-ruby/jwt:2
- >=dev-ruby/multi_json-1.3 =dev-ruby/multi_json-1*
- >=dev-ruby/multi_xml-0.5:0
- >=dev-ruby/rack-1.2:* <dev-ruby/rack-3:*"
-ruby_add_bdepend "test? (
- >=dev-ruby/addressable-2.3
- dev-ruby/rspec:3
- dev-ruby/rspec-stubbed_env
-)"
-
-all_ruby_prepare() {
- sed -e '/simplecov/,/^ end/ s:^:#:' \
- -e '/silent/I s:^:#:' \
- -e '1irequire "uri"' \
- -e '/require.*oauth2/arequire "oauth2/version"' \
- -i spec/helper.rb || die
-
- sed -i -e '/yardstick/,/^end/ s:^:#:' \
- -e '/bundler/I s:^:#:' Rakefile || die
-
- # Avoid spec that is too fragile in relation to ENV
- sed -i -e '/outputs to $stdout when OAUTH_DEBUG=true/a skip "fragile ENV stubbing"' spec/oauth2/client_spec.rb || die
-
- sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
-}
-
-each_ruby_test() {
- CI=true ${RUBY} -S rspec-3 spec || die
-}