summaryrefslogtreecommitdiff
path: root/dev-ruby/omniauth/omniauth-2.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-31 04:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-31 04:04:12 +0100
commit15d97fe857a00a52fd4efb0a31ed0560f9de3a24 (patch)
treefff97afa4cdc01dee4972402cf810f00aaec487a /dev-ruby/omniauth/omniauth-2.1.0.ebuild
parented6e9ebb6ab4abd792d5b15e97ec245603dd6e2d (diff)
gentoo auto-resync : 31:03:2023 - 04:04:12
Diffstat (limited to 'dev-ruby/omniauth/omniauth-2.1.0.ebuild')
-rw-r--r--dev-ruby/omniauth/omniauth-2.1.0.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-ruby/omniauth/omniauth-2.1.0.ebuild b/dev-ruby/omniauth/omniauth-2.1.0.ebuild
deleted file mode 100644
index 16d0da9a9ceb..000000000000
--- a/dev-ruby/omniauth/omniauth-2.1.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_EXTRADOC="README.md"
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A generalized Rack framework for multiple-provider authentication"
-HOMEPAGE="https://github.com/intridea/omniauth"
-SRC_URI="https://github.com/intridea/omniauth/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="MIT"
-KEYWORDS="~amd64"
-SLOT="$(ver_cut 1)"
-IUSE=""
-
-ruby_add_rdepend "
- >=dev-ruby/rack-2.2.3
- dev-ruby/rack-protection
- >=dev-ruby/hashie-3.4.6:*"
-ruby_add_bdepend "doc? ( dev-ruby/yard )
- test? ( dev-ruby/rack-test )"
-
-all_ruby_prepare() {
- sed -i -e '/[Bb]undler/d' \
- Rakefile ${PN}.gemspec || die "sed failed"
- sed -i -e '/RUBY_VERSION/,/^end/ s:^:#: ; /freeze/ s:^:#:' spec/helper.rb || die "sed failed"
- # maruku fails, resorting to default markdown implementation
- sed -i -e '/maruku/d' .yardopts || die "sed failed"
-
- sed -i -e '/s.files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
-}
-
-all_ruby_compile() {
- all_fakegem_compile
-
- if use doc ; then
- yard || die "yard failed"
- fi
-}