summaryrefslogtreecommitdiff
path: root/dev-ruby/open4/open4-1.3.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-ruby/open4/open4-1.3.4-r1.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-ruby/open4/open4-1.3.4-r1.ebuild')
-rw-r--r--dev-ruby/open4/open4-1.3.4-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/open4/open4-1.3.4-r1.ebuild b/dev-ruby/open4/open4-1.3.4-r1.ebuild
new file mode 100644
index 000000000000..ecf6798d3bdb
--- /dev/null
+++ b/dev-ruby/open4/open4-1.3.4-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Open3::popen3 with exit status"
+HOMEPAGE="https://github.com/ahoward/open4"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ mv rakefile Rakefile || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ dodoc -r samples
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -Itest/lib test/*.rb || die
+}